summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-08-31 03:35:06 +0100
committerSam James <sam@gentoo.org>2024-08-31 03:49:07 +0100
commitfb1e5b03c92bf64617787852b03a5848fca844cb (patch)
tree4c60cf0d496d93823c35801c1f0eef422a858a82 /dev-libs
parentmedia-libs/libdisplay-info: Keyword 0.1.1 ia64, #935235 (diff)
downloadgentoo-fb1e5b03c92bf64617787852b03a5848fca844cb.tar.gz
gentoo-fb1e5b03c92bf64617787852b03a5848fca844cb.tar.bz2
gentoo-fb1e5b03c92bf64617787852b03a5848fca844cb.zip
dev-libs/glib: handle dev-debug/systemtap[-dtrace-symlink]
See efb3a82e3496d3a52a1d04d4cbdb83b25655d96a. Bug: https://bugs.gentoo.org/938302 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/glib/glib-2.76.4.ebuild10
-rw-r--r--dev-libs/glib/glib-2.78.3.ebuild10
-rw-r--r--dev-libs/glib/glib-2.78.4-r1.ebuild10
-rw-r--r--dev-libs/glib/glib-2.78.6.ebuild10
-rw-r--r--dev-libs/glib/glib-2.80.4.ebuild11
5 files changed, 51 insertions, 0 deletions
diff --git a/dev-libs/glib/glib-2.76.4.ebuild b/dev-libs/glib/glib-2.76.4.ebuild
index 356bd10b8796..f296a348fdf3 100644
--- a/dev-libs/glib/glib-2.76.4.ebuild
+++ b/dev-libs/glib/glib-2.76.4.ebuild
@@ -178,7 +178,17 @@ multilib_src_configure() {
#esac
#fi
+ local native_file="${T}"/meson.${CHOST}.ini.local
+ # Workaround for bug #938302
+ if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
+ cat >> ${native_file} <<-EOF || die
+ [binaries]
+ dtrace='stap-dtrace'
+ EOF
+ fi
+
local emesonargs=(
+ --native-file "${native_file}"
-Dbuildtype=$(usex debug debug plain)
-Ddefault_library=$(usex static-libs both shared)
-Druntime_dir="${EPREFIX}"/run
diff --git a/dev-libs/glib/glib-2.78.3.ebuild b/dev-libs/glib/glib-2.78.3.ebuild
index 356bd10b8796..f296a348fdf3 100644
--- a/dev-libs/glib/glib-2.78.3.ebuild
+++ b/dev-libs/glib/glib-2.78.3.ebuild
@@ -178,7 +178,17 @@ multilib_src_configure() {
#esac
#fi
+ local native_file="${T}"/meson.${CHOST}.ini.local
+ # Workaround for bug #938302
+ if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
+ cat >> ${native_file} <<-EOF || die
+ [binaries]
+ dtrace='stap-dtrace'
+ EOF
+ fi
+
local emesonargs=(
+ --native-file "${native_file}"
-Dbuildtype=$(usex debug debug plain)
-Ddefault_library=$(usex static-libs both shared)
-Druntime_dir="${EPREFIX}"/run
diff --git a/dev-libs/glib/glib-2.78.4-r1.ebuild b/dev-libs/glib/glib-2.78.4-r1.ebuild
index f3dbbeb1f18b..07caf94eb0dc 100644
--- a/dev-libs/glib/glib-2.78.4-r1.ebuild
+++ b/dev-libs/glib/glib-2.78.4-r1.ebuild
@@ -187,7 +187,17 @@ multilib_src_configure() {
#esac
#fi
+ local native_file="${T}"/meson.${CHOST}.ini.local
+ # Workaround for bug #938302
+ if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
+ cat >> ${native_file} <<-EOF || die
+ [binaries]
+ dtrace='stap-dtrace'
+ EOF
+ fi
+
local emesonargs=(
+ --native-file "${native_file}"
$(meson_feature debug glib_debug)
-Ddefault_library=$(usex static-libs both shared)
-Druntime_dir="${EPREFIX}"/run
diff --git a/dev-libs/glib/glib-2.78.6.ebuild b/dev-libs/glib/glib-2.78.6.ebuild
index 4cb3fb6b75e4..19ae0fc69d73 100644
--- a/dev-libs/glib/glib-2.78.6.ebuild
+++ b/dev-libs/glib/glib-2.78.6.ebuild
@@ -186,7 +186,17 @@ multilib_src_configure() {
#esac
#fi
+ local native_file="${T}"/meson.${CHOST}.ini.local
+ # Workaround for bug #938302
+ if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
+ cat >> ${native_file} <<-EOF || die
+ [binaries]
+ dtrace='stap-dtrace'
+ EOF
+ fi
+
local emesonargs=(
+ --native-file "${native_file}"
$(meson_feature debug glib_debug)
-Ddefault_library=$(usex static-libs both shared)
-Druntime_dir="${EPREFIX}"/run
diff --git a/dev-libs/glib/glib-2.80.4.ebuild b/dev-libs/glib/glib-2.80.4.ebuild
index 1a20959666c2..2d87ba9d7a69 100644
--- a/dev-libs/glib/glib-2.80.4.ebuild
+++ b/dev-libs/glib/glib-2.80.4.ebuild
@@ -186,7 +186,18 @@ multilib_src_configure() {
#fi
use debug && EMESON_BUILD_TYPE=debug
+
+ local native_file="${T}"/meson.${CHOST}.ini.local
+ # Workaround for bug #938302
+ if use systemtap && ! has_version "dev-debug/systemtap[dtrace-symlink(-)]" ; then
+ cat >> ${native_file} <<-EOF || die
+ [binaries]
+ dtrace='stap-dtrace'
+ EOF
+ fi
+
local emesonargs=(
+ --native-file "${native_file}"
-Ddefault_library=$(usex static-libs both shared)
-Druntime_dir="${EPREFIX}"/run
$(meson_feature selinux)