summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2023-09-13 20:52:09 +0200
committerUlrich Müller <ulm@gentoo.org>2023-09-14 17:10:23 +0200
commitbab95f54c95b1279f45017dabee3f61a025d489e (patch)
treeec1da69f1335723510b1a455145edcbb80bee2fe /dev-lisp/ecl
parentapp-crypt/swtpm: add back support for swtpm_cert, improve description (diff)
downloadgentoo-bab95f54c95b1279f45017dabee3f61a025d489e.tar.gz
gentoo-bab95f54c95b1279f45017dabee3f61a025d489e.tar.bz2
gentoo-bab95f54c95b1279f45017dabee3f61a025d489e.zip
Package move dev-lisp/ecls to dev-lisp/ecl
Closes: https://bugs.gentoo.org/586230 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'dev-lisp/ecl')
-rw-r--r--dev-lisp/ecl/Manifest2
-rw-r--r--dev-lisp/ecl/ecl-21.2.1-r5.ebuild88
-rw-r--r--dev-lisp/ecl/ecl-23.9.9-r1.ebuild87
-rw-r--r--dev-lisp/ecl/files/README.gentoo13
-rw-r--r--dev-lisp/ecl/files/ecl-16.1.3-build.patch10
-rw-r--r--dev-lisp/ecl/files/ecl-16.1.3-headers-gentoo.patch15
-rw-r--r--dev-lisp/ecl/files/ecl-21.2.1-donotcompressinfo.patch35
-rw-r--r--dev-lisp/ecl/files/ecl-21.2.1-ldflags.patch13
-rw-r--r--dev-lisp/ecl/metadata.xml21
9 files changed, 284 insertions, 0 deletions
diff --git a/dev-lisp/ecl/Manifest b/dev-lisp/ecl/Manifest
new file mode 100644
index 000000000000..6cb34002d034
--- /dev/null
+++ b/dev-lisp/ecl/Manifest
@@ -0,0 +1,2 @@
+DIST ecl-21.2.1.tgz 7875088 BLAKE2B b8c05fab8ce5892ad9df830e3ad230e1c646bd30bc35243703ace18f1bf963057b132d980c74b364ff30a5b776a8f161e71bfd69d7908970811ab3dddbab1aac SHA512 0849bebe1a8073ea8027cfb172c1d7781d43adb6a8b80585bd08d5674b80422d1648b6fbf718cc17a51c5de6c696514523b4d13a82e8113bf9365c95d3c28648
+DIST ecl-23.9.9.tgz 8129105 BLAKE2B 883454e1b5459b348a2184727dc9d512988f3b8218370cbe01045e5bc401a6785cb736a16592d20ad9fe19e6518056ece5b809323fa7697304f39d31d60021fc SHA512 c8f1dcf2bffad7358c3d4e5bb0924cbb69afaf79871e6444bd780a594e1e96e6c547346b7c9c5184a6b12ce920a6a959334cf2a85c3f3ea0e0c8f22f72fb84df
diff --git a/dev-lisp/ecl/ecl-21.2.1-r5.ebuild b/dev-lisp/ecl/ecl-21.2.1-r5.ebuild
new file mode 100644
index 000000000000..a12f59e6b270
--- /dev/null
+++ b/dev-lisp/ecl/ecl-21.2.1-r5.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit readme.gentoo-r1
+
+DESCRIPTION="ECL is an embeddable Common Lisp implementation"
+HOMEPAGE="https://common-lisp.net/project/ecl/"
+SRC_URI="https://common-lisp.net/project/ecl/static/files/release/${P}.tgz"
+
+LICENSE="BSD-2 LGPL-2.1+"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~ppc ppc64 ~sparc x86 ~amd64-linux"
+IUSE="cxx debug emacs gengc precisegc cpu_flags_x86_sse +threads +unicode X"
+# test phase only works if ecl already installed #516876
+RESTRICT="test"
+
+RDEPEND="dev-libs/gmp:0=
+ dev-libs/libffi:=
+ dev-libs/libatomic_ops
+ >=dev-libs/boehm-gc-7.1[threads?]
+ >=dev-lisp/asdf-2.33-r3:="
+DEPEND="${RDEPEND}
+ app-text/texi2html
+ emacs? ( >=app-editors/emacs-23.1:* >=app-eselect/eselect-emacs-1.12 )"
+
+DOCS=( README.md CHANGELOG )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-16.1.3-headers-gentoo.patch"
+ "${FILESDIR}/${PN}-16.1.3-build.patch"
+ "${FILESDIR}/${PN}-21.2.1-donotcompressinfo.patch"
+ "${FILESDIR}/${PN}-21.2.1-ldflags.patch"
+)
+
+src_prepare() {
+ default
+ cp "${EPREFIX}"/usr/share/common-lisp/source/asdf/build/asdf.lisp contrib/asdf/ || die
+}
+
+src_configure() {
+ econf \
+ --enable-gmp=system \
+ --enable-boehm=system \
+ --with-dffi \
+ --enable-libatomic=system \
+ --with-defsystem \
+ $(use_with cxx) \
+ $(use_enable gengc) \
+ $(use_enable precisegc) \
+ $(use_with debug debug-cflags) \
+ $(use_with cpu_flags_x86_sse sse) \
+ $(use_enable threads) \
+ $(use_enable unicode) \
+ $(use_with X x)
+}
+
+src_compile() {
+ if use emacs; then
+ local ETAGS=$(eselect --brief etags list | sed -ne '/emacs/{p;q}')
+ [[ -n ${ETAGS} ]] || die "No etags implementation found"
+ pushd build > /dev/null || die
+ emake ETAGS=${ETAGS} TAGS
+ popd > /dev/null || die
+ else
+ touch build/TAGS
+ fi
+
+ ## for /proc/self/clear_refs (see #867052)
+ addpredict /proc
+
+ emake
+}
+
+src_install() {
+ default
+
+ readme.gentoo_create_doc
+ pushd build/doc > /dev/null || die
+ newman ecl.man ecl.1
+ newman ecl-config.man ecl-config.1
+ popd > /dev/null || die
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/dev-lisp/ecl/ecl-23.9.9-r1.ebuild b/dev-lisp/ecl/ecl-23.9.9-r1.ebuild
new file mode 100644
index 000000000000..37c1e50a8e0d
--- /dev/null
+++ b/dev-lisp/ecl/ecl-23.9.9-r1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit readme.gentoo-r1
+
+DESCRIPTION="ECL is an embeddable Common Lisp implementation"
+HOMEPAGE="https://common-lisp.net/project/ecl/"
+SRC_URI="https://common-lisp.net/project/ecl/static/files/release/${P}.tgz"
+
+LICENSE="BSD-2 LGPL-2.1+"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
+IUSE="cxx debug emacs gengc precisegc cpu_flags_x86_sse +threads +unicode X"
+# test phase only works if ecl already installed #516876
+RESTRICT="test"
+
+RDEPEND="dev-libs/gmp:0=
+ dev-libs/libffi:=
+ dev-libs/libatomic_ops
+ >=dev-libs/boehm-gc-7.1[threads?]
+ >=dev-lisp/asdf-2.33-r3:="
+DEPEND="${RDEPEND}
+ app-text/texi2html
+ emacs? ( >=app-editors/emacs-23.1:* >=app-eselect/eselect-emacs-1.12 )"
+
+DOCS=( README.md CHANGELOG )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-16.1.3-headers-gentoo.patch"
+ "${FILESDIR}/${PN}-16.1.3-build.patch"
+ "${FILESDIR}/${PN}-21.2.1-donotcompressinfo.patch"
+)
+
+src_prepare() {
+ default
+ cp "${EPREFIX}"/usr/share/common-lisp/source/asdf/build/asdf.lisp contrib/asdf/ || die
+}
+
+src_configure() {
+ econf \
+ --enable-gmp=system \
+ --enable-boehm=system \
+ --with-dffi \
+ --enable-libatomic=system \
+ --with-defsystem \
+ $(use_with cxx) \
+ $(use_enable gengc) \
+ $(use_enable precisegc) \
+ $(use_with debug debug-cflags) \
+ $(use_with cpu_flags_x86_sse sse) \
+ $(use_enable threads) \
+ $(use_enable unicode) \
+ $(use_with X x)
+}
+
+src_compile() {
+ if use emacs; then
+ local ETAGS=$(eselect --brief etags list | sed -ne '/emacs/{p;q}')
+ [[ -n ${ETAGS} ]] || die "No etags implementation found"
+ pushd build > /dev/null || die
+ emake ETAGS=${ETAGS} TAGS
+ popd > /dev/null || die
+ else
+ touch build/TAGS
+ fi
+
+ ## for /proc/self/clear_refs (see #867052)
+ addpredict /proc
+
+ emake
+}
+
+src_install() {
+ default
+
+ readme.gentoo_create_doc
+ pushd build/doc > /dev/null || die
+ newman ecl.man ecl.1
+ newman ecl-config.man ecl-config.1
+ popd > /dev/null || die
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/dev-lisp/ecl/files/README.gentoo b/dev-lisp/ecl/files/README.gentoo
new file mode 100644
index 000000000000..c95b6cb75167
--- /dev/null
+++ b/dev-lisp/ecl/files/README.gentoo
@@ -0,0 +1,13 @@
+-*- outline -*-
+
+Gentoo GNU/Linux specific notes for ECL
+---------------------------------------
+
+ * The Gentoo port includes a patch to ECL's installed header file (ech.h) so
+ that TRUE and FALSE are not redefined if they're already included from
+ elsewhere. This makes it easier to use ECL with other software which defines
+ those C preprocesser symbols (eg. glib-2.0).
+
+If you encounter any problems or have suggestions, use https://bugs.gentoo.org/.
+Please don't bother the upstream authors unless you are absolutely certain it is
+not Gentoo-related.
diff --git a/dev-lisp/ecl/files/ecl-16.1.3-build.patch b/dev-lisp/ecl/files/ecl-16.1.3-build.patch
new file mode 100644
index 000000000000..ff7d6cd74d8b
--- /dev/null
+++ b/dev-lisp/ecl/files/ecl-16.1.3-build.patch
@@ -0,0 +1,10 @@
+diff -r -U2 ecl-16.1.3.orig/src/c/printer/write_sse.d ecl-16.1.3/src/c/printer/write_sse.d
+--- ecl-16.1.3.orig/src/c/printer/write_sse.d 2016-12-19 17:25:00.000000000 +0700
++++ ecl-16.1.3/src/c/printer/write_sse.d 2016-12-19 19:20:01.863563607 +0700
+@@ -13,4 +13,6 @@
+ */
+
++#include <ecl/config.h>
++
+ #ifdef ECL_SSE2
+ #include <ecl/ecl.h>
diff --git a/dev-lisp/ecl/files/ecl-16.1.3-headers-gentoo.patch b/dev-lisp/ecl/files/ecl-16.1.3-headers-gentoo.patch
new file mode 100644
index 000000000000..10802aa48803
--- /dev/null
+++ b/dev-lisp/ecl/files/ecl-16.1.3-headers-gentoo.patch
@@ -0,0 +1,15 @@
+diff -r -U2 ecl-16.1.3.orig/src/h/object.h ecl-16.1.3/src/h/object.h
+--- ecl-16.1.3.orig/src/h/object.h 2016-12-19 17:25:00.000000000 +0700
++++ ecl-16.1.3/src/h/object.h 2016-12-19 19:22:21.147557750 +0700
+@@ -26,6 +26,11 @@
+ */
+
++#ifndef TRUE
+ #define TRUE 1 /* boolean true value */
++#endif
++
++#ifndef FALSE
+ #define FALSE 0 /* boolean false value */
++#endif
+
+ #if !defined(__cplusplus) && !defined(bool)
diff --git a/dev-lisp/ecl/files/ecl-21.2.1-donotcompressinfo.patch b/dev-lisp/ecl/files/ecl-21.2.1-donotcompressinfo.patch
new file mode 100644
index 000000000000..722e5dc7483f
--- /dev/null
+++ b/dev-lisp/ecl/files/ecl-21.2.1-donotcompressinfo.patch
@@ -0,0 +1,35 @@
+diff --git a/src/doc/Makefile.in b/src/doc/Makefile.in
+index 5660f41..c2aadbe 100644
+--- a/src/doc/Makefile.in
++++ b/src/doc/Makefile.in
+@@ -15,7 +15,7 @@ INSTALL_PROGRAM = @INSTALL_PROGRAM@
+ INSTALL_DATA = @INSTALL_DATA@
+ INSTALL_INFO = @INSTALL_INFO@
+ mkinstalldirs = $(top_srcdir)/bdwgc/install-sh -d
+-INFO_FILE = ecl.info.gz
++INFO_FILE = ecl.info
+ MAKEINFO = @MAKEINFO@
+ MANUAL_MAKE_TARGET = @MANUAL_MAKE_TARGET@
+ MANUAL_INSTALL_TARGET = @MANUAL_INSTALL_TARGET@
+diff --git a/src/doc/manual/Makefile b/src/doc/manual/Makefile
+index f82c287..2ff67e0 100644
+--- a/src/doc/manual/Makefile
++++ b/src/doc/manual/Makefile
+@@ -5,15 +5,14 @@ FILES= *.txi */*.txi figures/*
+ all: pdf info html
+
+ pdf: manual.pdf
+-info: ecl.info.gz
++info: ecl.info
+ html: html/index.html
+
+ manual.pdf: $(FILES)
+ texi2pdf manual.txi
+
+-ecl.info.gz: $(FILES)
++ecl.info: $(FILES)
+ $(MAKEINFO) --no-split manual.txi
+- gzip < ecl.info > ecl.info.gz
+
+ html/index.html: $(FILES)
+ $(MAKEINFO) --html --css-include=ecl.css --split=section manual.txi
diff --git a/dev-lisp/ecl/files/ecl-21.2.1-ldflags.patch b/dev-lisp/ecl/files/ecl-21.2.1-ldflags.patch
new file mode 100644
index 000000000000..5ac4cc5ea793
--- /dev/null
+++ b/dev-lisp/ecl/files/ecl-21.2.1-ldflags.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/723162
+
+--- ecl-21.2.1/src/c/Makefile.in
++++ ecl-21.2.1/src/c/Makefile.in
+@@ -104,7 +104,7 @@
+
+ $(DPP): $(srcdir)/dpp.c $(srcdir)/symbols_list.h
+ if test -f ../CROSS-DPP; then touch dpp; else \
+- $(TRUE_CC) -I$(srcdir) -I@true_builddir@ -I./ $(srcdir)/dpp.c @CPPFLAGS@ @CFLAGS@ @ECL_CFLAGS@ -o $@ ; \
++ $(TRUE_CC) -I$(srcdir) -I@true_builddir@ -I./ $(srcdir)/dpp.c @CPPFLAGS@ @CFLAGS@ @ECL_CFLAGS@ @LDFLAGS@ -o $@ ; \
+ fi
+
+ $(OBJS): $(DPP)
diff --git a/dev-lisp/ecl/metadata.xml b/dev-lisp/ecl/metadata.xml
new file mode 100644
index 000000000000..ec56a70b425e
--- /dev/null
+++ b/dev-lisp/ecl/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>common-lisp@gentoo.org</email>
+ <name>Gentoo Common Lisp Project</name>
+ </maintainer>
+ <longdescription>
+ ECL (Embeddable Common Lisp) is an implementation of the Common Lisp language as
+ described in the X3J13 Ansi specification, featuring CLOS (Common Lisp Object
+ System), conditions, loops, etc, plus a translator to C, which can produce
+ standalone executables.
+ </longdescription>
+ <use>
+ <flag name="gengc">Use generational garbage collection (experimental)</flag>
+ <flag name="precisegc">Use type information during garbage collection (experimental)</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">ecls</remote-id>
+ </upstream>
+</pkgmetadata>