summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-12-20 11:16:20 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-12-20 11:16:20 +0100
commit6b253ba96fec1d120073f75fdf8007ac9aba5547 (patch)
treeb0f48906d9dc38d70cbf97b2b98ad2ca4275643e /dev-lua/dkjson/dkjson-2.6.ebuild
parentapp-benchmarks/stress-ng: drop 0.13.08 (diff)
downloadgentoo-6b253ba96fec1d120073f75fdf8007ac9aba5547.tar.gz
gentoo-6b253ba96fec1d120073f75fdf8007ac9aba5547.tar.bz2
gentoo-6b253ba96fec1d120073f75fdf8007ac9aba5547.zip
dev-lua/dkjson: add 2.6
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/dkjson/dkjson-2.6.ebuild')
-rw-r--r--dev-lua/dkjson/dkjson-2.6.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-lua/dkjson/dkjson-2.6.ebuild b/dev-lua/dkjson/dkjson-2.6.ebuild
new file mode 100644
index 000000000000..44e0070057f6
--- /dev/null
+++ b/dev-lua/dkjson/dkjson-2.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="David Kolf's JSON module for Lua"
+HOMEPAGE="http://dkolf.de/src/dkjson-lua.fsl/"
+SRC_URI="http://dkolf.de/src/dkjson-lua.fsl/tarball/${P}.tar.gz?uuid=release_2_5 -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="${LUA_DEPS}"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ test? ( ${RDEPEND} )
+"
+
+DOCS=( "readme.txt" )
+
+lua_src_test() {
+ ${ELUA} jsontest.lua || die
+ ${ELUA} speedtest.lua ${PN} || die
+}
+
+src_test() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ insinto $(lua_get_lmod_dir)
+ doins dkjson.lua
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+
+ einstalldocs
+}