summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-01-27 21:45:25 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-01-27 22:59:50 +0100
commit0598ea89914982f85a6b008ba34442b93866254a (patch)
tree5e533488b8840db621c8839d76e413f03d092c7c /dev-ml/core_unix
parentdev-ml/core: add 0.15.1 (diff)
downloadgentoo-0598ea89914982f85a6b008ba34442b93866254a.tar.gz
gentoo-0598ea89914982f85a6b008ba34442b93866254a.tar.bz2
gentoo-0598ea89914982f85a6b008ba34442b93866254a.zip
dev-ml/core_unix: add 0.15.2
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/core_unix')
-rw-r--r--dev-ml/core_unix/Manifest1
-rw-r--r--dev-ml/core_unix/core_unix-0.15.2.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-ml/core_unix/Manifest b/dev-ml/core_unix/Manifest
index 182d7d23c228..c4f58231086c 100644
--- a/dev-ml/core_unix/Manifest
+++ b/dev-ml/core_unix/Manifest
@@ -1 +1,2 @@
DIST core_unix-0.15.0.tar.gz 377928 BLAKE2B 49b58471a28c356bdf39f15e22bd21ec4363182cf744c0455847ffc15015fdad2928a428986c2a9edff647ebef9f2ad2059b184b393e979119c8f007f67ec140 SHA512 eeb53bd0c06a7d1facfb133f0a45a232d57941eff644d4ed6c2d5002acd4e6b323376ec9c05838f760ebd9da3fbc39332989ed50b3921191c175811c947fcbfe
+DIST core_unix-0.15.2.tar.gz 377836 BLAKE2B 56551ab1509bfecc59ae4b45aaaa4d336415cffe9339932239c884bc86207bdb4066aace35144618509b78b461164bdfaaaa04030ecb1b3619de6f8fe5c3a7b9 SHA512 6d59c52111235f952f3052fb86af1d7380ff3d8d89b5c8d59a66d530a14d462fa4b06cdf29f2ee2b4356a574dbefef33b82f60f9fba512942bc0e6aad07f2b6f
diff --git a/dev-ml/core_unix/core_unix-0.15.2.ebuild b/dev-ml/core_unix/core_unix-0.15.2.ebuild
new file mode 100644
index 000000000000..2114a6c14a77
--- /dev/null
+++ b/dev-ml/core_unix/core_unix-0.15.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit dune
+
+DESCRIPTION="Unix-specific portions of Core"
+HOMEPAGE="https://github.com/janestreet/core_unix"
+SRC_URI="https://github.com/janestreet/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+DEPEND="
+ >=dev-lang/ocaml-4.09
+ dev-ml/core_kernel:${SLOT}
+ dev-ml/expect_test_helpers_core:${SLOT}
+ dev-ml/ocaml_intrinsics:${SLOT}
+ dev-ml/timezone:${SLOT}
+ dev-ml/spawn:${SLOT}
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""