summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ml/ocaml-text
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ml/ocaml-text')
-rw-r--r--dev-ml/ocaml-text/Manifest2
-rw-r--r--dev-ml/ocaml-text/metadata.xml8
-rw-r--r--dev-ml/ocaml-text/ocaml-text-0.6.ebuild31
-rw-r--r--dev-ml/ocaml-text/ocaml-text-0.8.ebuild37
4 files changed, 78 insertions, 0 deletions
diff --git a/dev-ml/ocaml-text/Manifest b/dev-ml/ocaml-text/Manifest
new file mode 100644
index 000000000000..a9a4e0ec3a65
--- /dev/null
+++ b/dev-ml/ocaml-text/Manifest
@@ -0,0 +1,2 @@
+DIST ocaml-text-0.6.tar.gz 253162 SHA256 cfd4d224ec0b776ce462c5ba5cb6e4eae8cf397ede6d3b91add44a05a6520f49 SHA512 83dffe6cb11634e81076d72a0ed4b1621705dae2657706c5629550e3a4a4b912258bb63cb913c5248ecb556c7484ab77be4d1063dc4c216ec680b363f854e305 WHIRLPOOL ac84bd4d7f5c1e8473cfaed4c8a5f47c4d20c38070974f21d6a5859ba8b069788562f911fcb98b607a62263714981efa39c76e811a83687e75dc0c113a9d3a4c
+DIST ocaml-text-0.8.tar.gz 80898 SHA256 bab32ca98a086631a0715d06109ebf09a71d2ac9aa901bc4f4ecd3d84331b746 SHA512 712afd21f615a81dc361ce7f5d89aff0c341ed91cd0e4cce6a2000361023b006b10731ce0cc6c025bde5f5fe7d07fa85ca2af65a8ad4d50647e8dfa8ff7ad81f WHIRLPOOL 1ae59a2cbffa7b9a9ce3a027df7b9eba0db69442ad99666439fc5833f2aa13120dfa18b155a9a11dfc0cce641260b3f1e29e652e61c584627526ffcf4e09d6bf
diff --git a/dev-ml/ocaml-text/metadata.xml b/dev-ml/ocaml-text/metadata.xml
new file mode 100644
index 000000000000..782e02637d6c
--- /dev/null
+++ b/dev-ml/ocaml-text/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ml</herd>
+ <upstream>
+ <remote-id type="github">vbmithr/ocaml-text</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-text/ocaml-text-0.6.ebuild b/dev-ml/ocaml-text/ocaml-text-0.6.ebuild
new file mode 100644
index 000000000000..d5689475d3e2
--- /dev/null
+++ b/dev-ml/ocaml-text/ocaml-text-0.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="library for dealing with 'text'"
+HOMEPAGE="http://forge.ocamlcore.org/projects/ocaml-text/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/937/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="pcre"
+
+DEPEND="virtual/libiconv
+ || ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )
+ pcre? ( dev-ml/pcre-ocaml:=[ocamlopt?] )"
+RDEPEND="${DEPEND}"
+
+DOCS=( "README" "CHANGES" "CHANGES.darcs" )
+
+src_configure() {
+ oasis_configure_opts="$(use_enable pcre)" \
+ oasis_src_configure
+}
diff --git a/dev-ml/ocaml-text/ocaml-text-0.8.ebuild b/dev-ml/ocaml-text/ocaml-text-0.8.ebuild
new file mode 100644
index 000000000000..3e29f391b163
--- /dev/null
+++ b/dev-ml/ocaml-text/ocaml-text-0.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="Library for dealing with 'text'"
+HOMEPAGE="https://github.com/vbmithr/ocaml-text/"
+SRC_URI="https://github.com/vbmithr/ocaml-text/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="pcre"
+
+RDEPEND="virtual/libiconv
+ dev-ml/camlp4:=
+ pcre? ( dev-ml/pcre-ocaml:=[ocamlopt?] )"
+DEPEND="${RDEPEND}
+ doc? ( dev-tex/rubber virtual/latex-base )"
+
+DOCS=( "README" "CHANGES" )
+
+src_configure() {
+ oasis_configure_opts="$(use_enable pcre)" \
+ oasis_src_configure
+}
+
+src_install() {
+ oasis_src_install
+ use doc && dodoc manual/*.pdf
+}