summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorigna_martinoli <ignamartinoli@protonmail.com>2022-08-18 01:24:17 -0300
committerAlfredo Tupone <tupone@gentoo.org>2022-09-09 19:18:46 +0200
commit78cc9e6d995c23b214e2c2ec3795b7a1c4a27a0d (patch)
treed2c5a218a21602347e64c61edbab3498163c0d98 /dev-ml/opam/opam-2.0.10-r1.ebuild
parentnet-misc/wget2: Keyword 2.0.1-r2 arm64, #869059 (diff)
downloadgentoo-78cc9e6d995c23b214e2c2ec3795b7a1c4a27a0d.tar.gz
gentoo-78cc9e6d995c23b214e2c2ec3795b7a1c4a27a0d.tar.bz2
gentoo-78cc9e6d995c23b214e2c2ec3795b7a1c4a27a0d.zip
dev-ml/opam: fix opam dependency on bubblewrap
Since opam 2.0.0~rc2, opam uses bwrap on Linux to run package instructions in a sandbox. Source: https://opam.ocaml.org/doc/FAQ.html#Why-does-opam-require-bwrap Signed-off-by: igna_martinoli <ignamartinoli@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/26904 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/opam/opam-2.0.10-r1.ebuild')
-rw-r--r--dev-ml/opam/opam-2.0.10-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-ml/opam/opam-2.0.10-r1.ebuild b/dev-ml/opam/opam-2.0.10-r1.ebuild
new file mode 100644
index 000000000000..6015a0f2830e
--- /dev/null
+++ b/dev-ml/opam/opam-2.0.10-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="A source-based package manager for OCaml"
+HOMEPAGE="http://opam.ocaml.org/"
+SRC_URI="https://github.com/ocaml/opam/archive/${PV/_/-}.tar.gz -> opam-${PV}.tar.gz"
+S="${WORKDIR}/opam-${PV/_/-}"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ dev-ml/cmdliner:=
+ dev-ml/cudf:=
+ >=dev-ml/dose3-6.0:=
+ dev-ml/extlib:=
+ ~dev-ml/opam-client-${PV}:=
+ dev-ml/opam-file-format:=
+ sys-apps/bubblewrap
+ dev-ml/re:="
+DEPEND="${RDEPEND}"
+
+# Cherry-picked from https://deb.debian.org/debian/pool/main/o/opam/opam_2.0.8-1.debian.tar.xz
+PATCHES=( "${FILESDIR}/debian-Port-to-Dose3-6.0.1.patch" )
+
+src_prepare() {
+ default
+
+ cat <<- EOF >> "${S}/dune"
+ (env
+ (dev
+ (flags (:standard -warn-error -3-9-33)))
+ (release
+ (flags (:standard -warn-error -3-9-33))))
+ EOF
+}