summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ml/optcomp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ml/optcomp')
-rw-r--r--dev-ml/optcomp/Manifest2
-rw-r--r--dev-ml/optcomp/metadata.xml8
-rw-r--r--dev-ml/optcomp/optcomp-1.5.ebuild23
-rw-r--r--dev-ml/optcomp/optcomp-1.6.ebuild23
4 files changed, 56 insertions, 0 deletions
diff --git a/dev-ml/optcomp/Manifest b/dev-ml/optcomp/Manifest
new file mode 100644
index 000000000000..15aee86bc96e
--- /dev/null
+++ b/dev-ml/optcomp/Manifest
@@ -0,0 +1,2 @@
+DIST optcomp-1.5.tar.gz 51964 SHA256 1041762f2a5ba014b26a24c31ed46c6c08cd89754c8914388f358161b7e97d8d SHA512 15fc215e19e4e7854d5b6b005ece6301e5847cf8cdfc1d017a858fd3a0fd4309346e4347c2ab29902d929d67d284a279001ae518b498c997e1648bfcd2513142 WHIRLPOOL 1a88fa85f626a590d9edca8a1551ac963338ae7a68f5f7c3ab028b5251d696c83473eb8ebfddaf653421409af79bd01ff07084c27009b839c0251d0959dedd41
+DIST optcomp-1.6.tar.gz 56370 SHA256 5022d80e4d7dba4ada3aa57156503fad75fcd6d7b13cfa8580012a1d9f581042 SHA512 19fa04a42e5ed589979647469759017442598d170bf82d49c3b720d1b1b6bbe3066ae3ffee77a3f15dcbf51be5d7a8934300873391ebce423f3a0f3878250c18 WHIRLPOOL ca453c60a367e58747363cb9f4d20f7e34c3f1a63a767104903b810d1e50007bca6340ed517cc98a0563ad6bf0e934ff3ded448a441627280c7e6a51097ca676
diff --git a/dev-ml/optcomp/metadata.xml b/dev-ml/optcomp/metadata.xml
new file mode 100644
index 000000000000..d5c2ef5378ef
--- /dev/null
+++ b/dev-ml/optcomp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ml</herd>
+ <upstream>
+ <remote-id type="github">diml/optcomp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/optcomp/optcomp-1.5.ebuild b/dev-ml/optcomp/optcomp-1.5.ebuild
new file mode 100644
index 000000000000..01e62206913e
--- /dev/null
+++ b/dev-ml/optcomp/optcomp-1.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Optional compilation for OCaml with cpp-like directives"
+HOMEPAGE="http://github.com/diml/optcomp"
+SRC_URI="http://github.com/diml/optcomp/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+DOCS=( CHANGES.md README.md )
diff --git a/dev-ml/optcomp/optcomp-1.6.ebuild b/dev-ml/optcomp/optcomp-1.6.ebuild
new file mode 100644
index 000000000000..e210066ae355
--- /dev/null
+++ b/dev-ml/optcomp/optcomp-1.6.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Optional compilation for OCaml with cpp-like directives"
+HOMEPAGE="http://github.com/diml/optcomp"
+SRC_URI="http://github.com/diml/optcomp/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="|| ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )"
+RDEPEND="${DEPEND}"
+
+DOCS=( CHANGES.md README.md )