summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2021-12-03 03:49:04 +0100
committerMaciej Barć <xgqt@gentoo.org>2021-12-03 03:49:14 +0100
commitb3b6632b81a39255e67621bad656630d5eadd3ad (patch)
tree7df7e3c5fc89bd85c3a1a8a13946e53e21a784b8 /dev-ml/ppx_deriving_yojson
parentnet-misc/olsrd: don't call ldconfig (fix musl install) (diff)
downloadgentoo-b3b6632b81a39255e67621bad656630d5eadd3ad.tar.gz
gentoo-b3b6632b81a39255e67621bad656630d5eadd3ad.tar.bz2
gentoo-b3b6632b81a39255e67621bad656630d5eadd3ad.zip
dev-ml/ppx_deriving_yojson: new package; add version 3.6.1
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_deriving_yojson')
-rw-r--r--dev-ml/ppx_deriving_yojson/Manifest1
-rw-r--r--dev-ml/ppx_deriving_yojson/files/ppx_deriving_yojson-3.6.1-src_test_dune-ounit2.patch12
-rw-r--r--dev-ml/ppx_deriving_yojson/metadata.xml13
-rw-r--r--dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.6.1.ebuild27
4 files changed, 53 insertions, 0 deletions
diff --git a/dev-ml/ppx_deriving_yojson/Manifest b/dev-ml/ppx_deriving_yojson/Manifest
new file mode 100644
index 000000000000..3474db68ca3e
--- /dev/null
+++ b/dev-ml/ppx_deriving_yojson/Manifest
@@ -0,0 +1 @@
+DIST ppx_deriving_yojson-3.6.1.tar.gz 19477 BLAKE2B f7b4e34e1c5ca77af6dbe6f4639c00a3b47076e2cf1f79b157a4c8f9aef34ec0e95e2c6c805fe9d0f9fa0ec72ea0672696b7e7a21d0a7d93764fad2e8d89a15a SHA512 b1bf04f77e1c1a887352b21cfd43a67d37de9f61a70f89d06828c7d9611027711a600b22e4bbc95ab128511a48fce3ae1a1c7a655f25c4bb2b6944444cea4989
diff --git a/dev-ml/ppx_deriving_yojson/files/ppx_deriving_yojson-3.6.1-src_test_dune-ounit2.patch b/dev-ml/ppx_deriving_yojson/files/ppx_deriving_yojson-3.6.1-src_test_dune-ounit2.patch
new file mode 100644
index 000000000000..ad27a24d39f1
--- /dev/null
+++ b/dev-ml/ppx_deriving_yojson/files/ppx_deriving_yojson-3.6.1-src_test_dune-ounit2.patch
@@ -0,0 +1,12 @@
+diff --git a/src_test/dune b/src_test/dune_
+index f7a8440..d5337c5 100644
+--- a/src_test/dune
++++ b/src_test/dune_
+@@ -1,6 +1,6 @@
+ (executable
+ (name test_ppx_yojson)
+- (libraries oUnit result)
++ (libraries ounit2 result)
+ (preprocess (pps ppx_deriving.show ppx_deriving_yojson))
+ (flags (:standard -w -9-39-27-34-37)))
+
diff --git a/dev-ml/ppx_deriving_yojson/metadata.xml b/dev-ml/ppx_deriving_yojson/metadata.xml
new file mode 100644
index 000000000000..3db44a512450
--- /dev/null
+++ b/dev-ml/ppx_deriving_yojson/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/ocaml-ppx/ppx_deriving_yojson/issues</bugs-to>
+ <remote-id type="github">ocaml-ppx/ppx_deriving_yojson</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.6.1.ebuild b/dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.6.1.ebuild
new file mode 100644
index 000000000000..603d1909b88f
--- /dev/null
+++ b/dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.6.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="JSON codec generator for OCaml"
+HOMEPAGE="https://github.com/ocaml-ppx/ppx_deriving_yojson/"
+SRC_URI="https://github.com/ocaml-ppx/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+PATCHES=( "${FILESDIR}"/${PN}-${PV}-src_test_dune-ounit2.patch )
+
+RDEPEND="
+ <dev-ml/yojson-2.0.0:=
+ >=dev-ml/ppxlib-0.20.0:=
+ dev-ml/ppx_deriving:=
+ dev-ml/result:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="test? ( dev-ml/ounit2 )"