summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-06-03 17:25:29 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-06-03 17:51:03 +0200
commit478726065ae1ef60e2be07d311ed7022a7d297c7 (patch)
tree81f8fa705541c0260361cd57f7dbf73dafb39e4f /dev-ml/zmq-lwt/zmq-lwt-5.2.1.ebuild
parentdev-ml/zmq-async: new package; add 5.2.1 (diff)
downloadgentoo-478726065ae1ef60e2be07d311ed7022a7d297c7.tar.gz
gentoo-478726065ae1ef60e2be07d311ed7022a7d297c7.tar.bz2
gentoo-478726065ae1ef60e2be07d311ed7022a7d297c7.zip
dev-ml/zmq-lwt: new package; add 5.2.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-ml/zmq-lwt/zmq-lwt-5.2.1.ebuild')
-rw-r--r--dev-ml/zmq-lwt/zmq-lwt-5.2.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-ml/zmq-lwt/zmq-lwt-5.2.1.ebuild b/dev-ml/zmq-lwt/zmq-lwt-5.2.1.ebuild
new file mode 100644
index 000000000000..729eb085aacf
--- /dev/null
+++ b/dev-ml/zmq-lwt/zmq-lwt-5.2.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Lwt-aware bindings to ZMQ for OCaml"
+HOMEPAGE="https://github.com/issuu/ocaml-zmq/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/issuu/ocaml-zmq.git"
+else
+ SRC_URI="https://github.com/issuu/ocaml-zmq/archive/${PV}.tar.gz
+ -> ocaml-zmq-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+S="${WORKDIR}"/ocaml-zmq-${PV}
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-ml/lwt:=
+ net-libs/zeromq:=
+"
+DEPEND="${DEPEND}"
+BDEPEND="
+ dev-ml/dune-configurator
+ test? ( dev-ml/ounit2 )
+"
+
+src_compile() {
+ dune-compile ${DUNE_PKG_NAME}
+}
+
+src_test() {
+ dune-test ${DUNE_PKG_NAME}
+}