summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-21 00:24:25 +0000
committerSam James <sam@gentoo.org>2021-04-21 02:09:33 +0000
commit6fa08eff8c8086742b6034cf33629a13054cd238 (patch)
tree5fdace61bea3dc39cb2a7eb845dff836fedbcfdc /dev-ml
parentdev-ml/ocaml-augeas: port to EAPI 7 (diff)
downloadgentoo-6fa08eff8c8086742b6034cf33629a13054cd238.tar.gz
gentoo-6fa08eff8c8086742b6034cf33629a13054cd238.tar.bz2
gentoo-6fa08eff8c8086742b6034cf33629a13054cd238.zip
dev-ml/ocaml-doc: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-doc/ocaml-doc-4.04.ebuild22
-rw-r--r--dev-ml/ocaml-doc/ocaml-doc-4.05.ebuild22
2 files changed, 20 insertions, 24 deletions
diff --git a/dev-ml/ocaml-doc/ocaml-doc-4.04.ebuild b/dev-ml/ocaml-doc/ocaml-doc-4.04.ebuild
index 46e0e0b6687c..b15602118ee4 100644
--- a/dev-ml/ocaml-doc/ocaml-doc-4.04.ebuild
+++ b/dev-ml/ocaml-doc/ocaml-doc-4.04.ebuild
@@ -1,24 +1,22 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
DESCRIPTION="Ocaml reference manual (html)"
-HOMEPAGE="http://caml.inria.fr/pub/docs/manual-ocaml/"
-SRC_URI="http://caml.inria.fr/pub/distrib/ocaml-${PV}/ocaml-${PV}-refman-html.tar.gz"
-LICENSE="GPL-2"
-
-KEYWORDS="amd64 ~ppc x86"
+HOMEPAGE="https://caml.inria.fr/pub/docs/manual-ocaml/"
+SRC_URI="https://caml.inria.fr/pub/distrib/ocaml-${PV}/ocaml-${PV}-refman-html.tar.gz"
+S="${WORKDIR}"/htmlman
+LICENSE="GPL-2"
SLOT="0"
-IUSE=""
-
-S=${WORKDIR}/htmlman
+KEYWORDS="amd64 ~ppc x86"
src_install() {
- dohtml -r *
+ docinto html
+ dodoc -r *
}
pkg_postinst() {
- elog "This manual is available online at http://caml.inria.fr/pub/docs/manual-ocaml/"
+ elog "This manual is available online at https://caml.inria.fr/pub/docs/manual-ocaml/"
}
diff --git a/dev-ml/ocaml-doc/ocaml-doc-4.05.ebuild b/dev-ml/ocaml-doc/ocaml-doc-4.05.ebuild
index 198cd811e65f..0cd8b61b87c8 100644
--- a/dev-ml/ocaml-doc/ocaml-doc-4.05.ebuild
+++ b/dev-ml/ocaml-doc/ocaml-doc-4.05.ebuild
@@ -1,24 +1,22 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
DESCRIPTION="Ocaml reference manual (html)"
-HOMEPAGE="http://caml.inria.fr/pub/docs/manual-ocaml/"
-SRC_URI="http://caml.inria.fr/pub/distrib/ocaml-${PV}/ocaml-${PV}-refman-html.tar.gz"
-LICENSE="GPL-2"
-
-KEYWORDS="~amd64 ~ppc ~x86"
+HOMEPAGE="https://caml.inria.fr/pub/docs/manual-ocaml/"
+SRC_URI="https://caml.inria.fr/pub/distrib/ocaml-${PV}/ocaml-${PV}-refman-html.tar.gz"
+S="${WORKDIR}"/htmlman
+LICENSE="GPL-2"
SLOT="0"
-IUSE=""
-
-S=${WORKDIR}/htmlman
+KEYWORDS="~amd64 ~ppc ~x86"
src_install() {
- dohtml -r *
+ docinto html
+ dodoc -r *
}
pkg_postinst() {
- elog "This manual is available online at http://caml.inria.fr/pub/docs/manual-ocaml/"
+ elog "This manual is available online at https://caml.inria.fr/pub/docs/manual-ocaml/"
}