summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-12-16 11:24:23 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-12-16 12:06:38 +0100
commitf25192329b0a9abdd5f948b50166c5a3f566fa73 (patch)
tree897cb40c7dc2aad450d2d6dfd7dae770f97c694e /dev-ml
parentdev-ml/parmap: bump to 1.2.5 (diff)
downloadgentoo-f25192329b0a9abdd5f948b50166c5a3f566fa73.tar.gz
gentoo-f25192329b0a9abdd5f948b50166c5a3f566fa73.tar.bz2
gentoo-f25192329b0a9abdd5f948b50166c5a3f566fa73.zip
dev-ml/ocamlbuild: bump to 0.14.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocamlbuild/Manifest1
-rw-r--r--dev-ml/ocamlbuild/ocamlbuild-0.14.2.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-ml/ocamlbuild/Manifest b/dev-ml/ocamlbuild/Manifest
index 654742222d98..b14a70fb840e 100644
--- a/dev-ml/ocamlbuild/Manifest
+++ b/dev-ml/ocamlbuild/Manifest
@@ -1,3 +1,4 @@
DIST ocamlbuild-0.11.0.tar.gz 195297 BLAKE2B 2d653c402edf58035fa6efb65c99c956fe78efc4759f29c8ddab8263310a5d243d25d37d4c1a4f0699f151afb6d4c6df4c1550f95d6e915963b3d86923877225 SHA512 14bc44cc63b6c99e711658a1145247bad8263632fbb4550238cef15e226a76b83e51b83575a7a96f16b96ec321dedd0ef23f36166c354838aec1922f58179efd
DIST ocamlbuild-0.14.0.tar.gz 198267 BLAKE2B 355d61ba68e61b9ee18a9fc0fbb9062405f44707b180ca7ad4bfec727ca3d3d2cc08f17be118ca3a4161c7789d975e7f431812e9139d4fde85a1a27ab68c8ac3 SHA512 ae60247396399dfd35644c8c1986ef7679e5a9964df82e3388bfc6dd4c5b88a13d6869a698d14a9ac70dc48e4ce1c003f543c85426d8c862ca31dea37a554b07
DIST ocamlbuild-0.14.1.tar.gz 199103 BLAKE2B e29d5cf2b333dd45c0aa86cc1fa4ddb160079b8a7badfe6127039d9215d3e6ad655eeacc9410887eadf1d61615025a59ea008254cae5fd65c13eb2afc7937ec8 SHA512 1f5b43215b1d3dc427b9c64e005add9d423ed4bca9686d52c55912df8955647cb2d7d86622d44b41b14c4f0d657b770c27967c541c868eeb7c78e3bd35b827ad
+DIST ocamlbuild-0.14.2.tar.gz 199293 BLAKE2B d81613878f93f27c6de41461e6b3cebe0744a5204297725263a608cb129a708aaf6f27b444b97d68f2bde844a760f8e78647641f10eed61e727ef3936562cdea SHA512 f568bf10431a1f701e8bd7554dc662400a0d978411038bbad93d44dceab02874490a8a5886a9b44e017347e7949997f13f5c3752f74e1eb5e273d2beb19a75fd
diff --git a/dev-ml/ocamlbuild/ocamlbuild-0.14.2.ebuild b/dev-ml/ocamlbuild/ocamlbuild-0.14.2.ebuild
new file mode 100644
index 000000000000..73f2c700e2ce
--- /dev/null
+++ b/dev-ml/ocamlbuild/ocamlbuild-0.14.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Generic build tool with built-in rules for building OCaml library and programs"
+HOMEPAGE="https://github.com/ocaml/ocamlbuild"
+SRC_URI="https://github.com/ocaml/ocamlbuild/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="+ocamlopt"
+RESTRICT="test" # Tests fail
+
+RDEPEND=">=dev-lang/ocaml-4.02.3-r1:=[ocamlopt?]"
+DEPEND="${RDEPEND}
+ dev-ml/findlib"
+
+QA_FLAGS_IGNORED='.*'
+src_prepare() {
+ sed -i \
+ -e "/package_exists/s:camlp4.macro:xxxxxx:" \
+ -e "/package_exists/s:menhirLib:xxxxxx:" \
+ testsuite/external.ml || die
+ default
+}
+
+src_configure() {
+ emake -f configure.make Makefile.config \
+ PREFIX="${EPREFIX}/usr" \
+ BINDIR="${EPREFIX}/usr/bin" \
+ LIBDIR="$(ocamlc -where)" \
+ OCAML_NATIVE=$(usex ocamlopt true false) \
+ OCAML_NATIVE_TOOLS=$(usex ocamlopt true false) \
+ NATDYNLINK=$(usex ocamlopt true false)
+}
+
+src_compile() {
+ emake src/ocamlbuild_config.cmo
+ default
+}
+
+src_install() {
+ emake CHECK_IF_PREINSTALLED=false DESTDIR="${D}" install
+ dodoc Changes
+}