summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlain Emilia Anna Zscheile <fogti@ytrizja.de>2024-07-13 21:32:35 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-07-15 15:56:18 +0200
commitfe7b6ae69e38f506d3dc8179e401dd68b1877200 (patch)
tree2c3bfb242cf6e848103cb7af0b6cf557cb942a91 /dev-ml
parentdev-ml/zarith: update EAPI 7 -> 8 (diff)
downloadgentoo-fe7b6ae69e38f506d3dc8179e401dd68b1877200.tar.gz
gentoo-fe7b6ae69e38f506d3dc8179e401dd68b1877200.tar.bz2
gentoo-fe7b6ae69e38f506d3dc8179e401dd68b1877200.zip
dev-ml/dose3: remove unnecessary dependencies on archivers
This also fixes unnecessary [ocamlopt=] use-flag dependencies. Signed-off-by: Alain Emilia Anna Zscheile <fogti@ytrizja.de> Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/dose3/dose3-7.0.0-r1.ebuild41
-rw-r--r--dev-ml/dose3/metadata.xml4
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-ml/dose3/dose3-7.0.0-r1.ebuild b/dev-ml/dose3/dose3-7.0.0-r1.ebuild
new file mode 100644
index 000000000000..d5d0e6ece2c4
--- /dev/null
+++ b/dev-ml/dose3/dose3-7.0.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Library to perform analysis on package repositories"
+HOMEPAGE="http://www.mancoosi.org/software/ https://gforge.inria.fr/projects/dose"
+SRC_URI="https://gitlab.com/irill/${PN}/-/archive/${PV}/${P}.tar.bz2"
+S="${WORKDIR}/${PN}-$(ver_cut 1-3)"
+
+LICENSE="LGPL-3+" # with OCaml linking exception
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+BDEPEND="
+ dev-ml/findlib
+ dev-ml/ocamlbuild
+"
+# NOTE: dependencies on RPM, camlbz2, ZIP are unnecessary,
+# because those are only used by dose3-extra
+RDEPEND="
+ dev-ml/ocaml-base64:=[ocamlopt?]
+ dev-ml/cudf:=[ocamlopt?]
+ >=dev-ml/extlib-1.7.8:=[ocamlopt?]
+ dev-ml/ocamlgraph:=[ocamlopt?]
+ dev-ml/re:=[ocamlopt?]
+ dev-ml/parmap:=[ocamlopt?]
+ dev-ml/ocaml-expat:=[ocamlopt?]
+ dev-ml/xml-light:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}"
+
+# missing test data
+RESTRICT="test"
+
+src_compile() {
+ dune-compile ${PN}
+}
diff --git a/dev-ml/dose3/metadata.xml b/dev-ml/dose3/metadata.xml
index 353924ec9e4e..447e2daf958d 100644
--- a/dev-ml/dose3/metadata.xml
+++ b/dev-ml/dose3/metadata.xml
@@ -1,6 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <maintainer type="person">
+ <email>fogti@ytrizja.de</email>
+ <name>Alain Emilia Anna Zscheile</name>
+ </maintainer>
<maintainer type="project">
<email>ml@gentoo.org</email>
<name>ML</name>