summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-22 04:51:48 +0100
committerSam James <sam@gentoo.org>2023-06-22 04:54:05 +0100
commit728df1fbf6cffa37c6f3bf69eb5a4bb4bf32f656 (patch)
tree07fcddc26eed7ab4422e38f4812c78212662e04a /dev-perl/Carp-Assert-More/Carp-Assert-More-2.3.0.ebuild
parentdev-perl/CBOR-XS: add 1.860.0 (diff)
downloadgentoo-728df1fbf6cffa37c6f3bf69eb5a4bb4bf32f656.tar.gz
gentoo-728df1fbf6cffa37c6f3bf69eb5a4bb4bf32f656.tar.bz2
gentoo-728df1fbf6cffa37c6f3bf69eb5a4bb4bf32f656.zip
dev-perl/Carp-Assert-More: add 2.3.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/Carp-Assert-More/Carp-Assert-More-2.3.0.ebuild')
-rw-r--r--dev-perl/Carp-Assert-More/Carp-Assert-More-2.3.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/Carp-Assert-More/Carp-Assert-More-2.3.0.ebuild b/dev-perl/Carp-Assert-More/Carp-Assert-More-2.3.0.ebuild
new file mode 100644
index 000000000000..3c7a6612e2a5
--- /dev/null
+++ b/dev-perl/Carp-Assert-More/Carp-Assert-More-2.3.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=PETDANCE
+inherit perl-module
+
+DESCRIPTION="Convenience assertions for common situations"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Scalar-List-Utils
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Test-Exception
+ >=virtual/perl-Test-Simple-0.180.0
+ )
+"
+
+PERL_RM_FILES=(
+ "t/pod-coverage.t"
+ "t/pod.t"
+)