summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-08-31 18:01:40 +1200
committerKent Fredric <kentnl@gentoo.org>2020-08-31 18:01:40 +1200
commita71a1f5ec971aae2829eda6dc6f8409ef496c458 (patch)
tree8699411764d628acad53b1f42346bf6ca5a6a179 /dev-perl/File-Next
parentdev-perl/File-NFSLock: Bump to version 1.270.0 (diff)
downloadgentoo-a71a1f5ec971aae2829eda6dc6f8409ef496c458.tar.gz
gentoo-a71a1f5ec971aae2829eda6dc6f8409ef496c458.tar.bz2
gentoo-a71a1f5ec971aae2829eda6dc6f8409ef496c458.zip
dev-perl/File-Next: -r bump for various fixes
- Fix DESCRIPTION - Fix LICENSE (GPL2+ required due to bundled test file) - Fix use of DEPEND instead of BDEPEND - Improve dependencies Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/File-Next')
-rw-r--r--dev-perl/File-Next/File-Next-1.180.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/File-Next/File-Next-1.180.0-r1.ebuild b/dev-perl/File-Next/File-Next-1.180.0-r1.ebuild
new file mode 100644
index 000000000000..78b02898668e
--- /dev/null
+++ b/dev-perl/File-Next/File-Next-1.180.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=PETDANCE
+DIST_VERSION=1.18
+inherit perl-module
+
+DESCRIPTION="An iterator-based module for finding files"
+
+LICENSE="Artistic-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="virtual/perl-File-Spec"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-File-Temp-0.220.0
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"
+
+src_test() {
+ # Ugh, Upstream has tests that depend on tests ...
+ echo 'print qq[1..1\nok 1];' > "${S}/t/pod.t"
+ echo 'print qq[1..1\nok 1];' > "${S}/t/pod-coverage.t"
+ perl-module_src_test
+}