summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Brewer <tomboy64@sina.cn>2016-04-01 15:11:56 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-04-03 23:23:43 +0200
commitc2a5f67044967154d7ace5a30e2680734a6a984a (patch)
treed59e59342ba34447a0332cadbf604cac05c1de4e /dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.140.0.ebuild
parentdev-perl/Growl-GNTP: initial ebuild, version 0.200.0 (diff)
downloadgentoo-c2a5f67044967154d7ace5a30e2680734a6a984a.tar.gz
gentoo-c2a5f67044967154d7ace5a30e2680734a6a984a.tar.bz2
gentoo-c2a5f67044967154d7ace5a30e2680734a6a984a.zip
dev-perl/Math-BigInt-Lite: initial ebuild, version 0.140.0
Package-Manager: portage-2.2.28 RepoMan-Options: --ignore-arches
Diffstat (limited to 'dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.140.0.ebuild')
-rw-r--r--dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.140.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.140.0.ebuild b/dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.140.0.ebuild
new file mode 100644
index 000000000000..1e7b1afedab0
--- /dev/null
+++ b/dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.140.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR="FLORA"
+DIST_VERSION=0.14
+inherit perl-module
+
+DESCRIPTION="What BigInts are before they become big"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=virtual/perl-Math-BigInt-1.940.0
+ >=virtual/perl-Math-BigRat-0.190.0"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.420.0
+ test? ( >=virtual/perl-Test-Simple-0.520.0 )"
+
+src_test() {
+ local bad_files=( "t/pod_cov.t" "t/pod.t" );
+ einfo "t/bigintpm.t is broken: https://rt.cpan.org/Public/Bug/Display.html?id=75667";
+ bad_files+=( "t/bigintpm.t" );
+ perl_rm_files "${bad_files[@]}";
+
+ perl-module_src_test;
+}