summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Net-XMPP
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Net-XMPP')
-rw-r--r--dev-perl/Net-XMPP/Manifest1
-rw-r--r--dev-perl/Net-XMPP/Net-XMPP-1.20.0-r1.ebuild41
-rw-r--r--dev-perl/Net-XMPP/files/1.02-defined.patch14
-rw-r--r--dev-perl/Net-XMPP/metadata.xml22
4 files changed, 78 insertions, 0 deletions
diff --git a/dev-perl/Net-XMPP/Manifest b/dev-perl/Net-XMPP/Manifest
new file mode 100644
index 000000000000..089aa6f37fdf
--- /dev/null
+++ b/dev-perl/Net-XMPP/Manifest
@@ -0,0 +1 @@
+DIST Net-XMPP-1.02.tar.gz 121653 SHA256 69761441e214042b10b6608afaffbb1b5262e4aaaddb4b315dbf2ea48c4742ea SHA512 7a373e627de7e909ef50d6525b438dd7f094c7e6ad3cb66fff6087048fe9b127e376cf45d1621e55deec2c59fe043ff19f180d0b264fa1dd0c392701dfc43497 WHIRLPOOL e3238e9dac4caf00de645c9eadbc530b725a6872a89ee82043931b7d21a6375419554020dc573aeed3b4415f8a65ddc4685c497bfe1951dd5d802d4fb8557b70
diff --git a/dev-perl/Net-XMPP/Net-XMPP-1.20.0-r1.ebuild b/dev-perl/Net-XMPP/Net-XMPP-1.20.0-r1.ebuild
new file mode 100644
index 000000000000..290fbdb43ddd
--- /dev/null
+++ b/dev-perl/Net-XMPP/Net-XMPP-1.20.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=HACKER
+MODULE_VERSION=1.02
+inherit perl-module
+
+DESCRIPTION="XMPP Perl Library"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND=">=dev-perl/XML-Stream-1.22
+ dev-perl/Digest-SHA1"
+DEPEND="dev-perl/Module-Build
+ ${RDEPEND}"
+
+SRC_TEST="do"
+PATCHES=( "${FILESDIR}"/1.02-defined.patch )
+
+src_prepare() {
+ for i in 2_client_jabberd1.4.t 3_client_jabberd2.t ; do
+ mv "${S}"/t/${i}{,.disable} || die
+ sed -i -e "/${i}/d" "${S}"/MANIFEST || die
+ done
+ perl-module_src_prepare
+}
+
+src_test() {
+ # bug 526390
+ # this test fails in version 1.02.
+ # please comment out this section when bumping the package
+ # to check whether it still fails.
+ perl_rm_files t/roster.t
+ perl-module_src_test
+}
diff --git a/dev-perl/Net-XMPP/files/1.02-defined.patch b/dev-perl/Net-XMPP/files/1.02-defined.patch
new file mode 100644
index 000000000000..adac59b481e4
--- /dev/null
+++ b/dev-perl/Net-XMPP/files/1.02-defined.patch
@@ -0,0 +1,14 @@
+https://rt.cpan.org/Public/Bug/Display.html?id=58333
+http://github.com/dap/Net-XMPP/commit/2d1164d7c50d7c034f3d1efb03ad9319b24dfd24
+
+--- Net-XMPP-1.02/lib/Net/XMPP/Debug.pm
++++ Net-XMPP-1.02/lib/Net/XMPP/Debug.pm
+@@ -151,7 +151,7 @@
+ my %args;
+ while($#_ >= 0) { $args{ lc pop(@_) } = pop(@_); }
+
+- delete($args{file}) if (lc($args{file}) eq "stdout");
++ delete($args{file}) if (defined $args{file} && lc($args{file}) eq "stdout");
+
+ $args{time} = 0 if !exists($args{time});
+ $args{setdefault} = 0 if !exists($args{setdefault});
diff --git a/dev-perl/Net-XMPP/metadata.xml b/dev-perl/Net-XMPP/metadata.xml
new file mode 100644
index 000000000000..6b331c63038e
--- /dev/null
+++ b/dev-perl/Net-XMPP/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <longdescription>Net::XMPP is a collection of Perl modules that provide a Perl Developer access to the XMPP protocol.</longdescription>
+ <upstream>
+ <remote-id type="cpan">Net-XMPP</remote-id>
+ <remote-id type="cpan-module">Net::XMPP</remote-id>
+ <remote-id type="cpan-module">Net::XMPP::Client</remote-id>
+ <remote-id type="cpan-module">Net::XMPP::Connection</remote-id>
+ <remote-id type="cpan-module">Net::XMPP::Debug</remote-id>
+ <remote-id type="cpan-module">Net::XMPP::IQ</remote-id>
+ <remote-id type="cpan-module">Net::XMPP::JID</remote-id>
+ <remote-id type="cpan-module">Net::XMPP::Message</remote-id>
+ <remote-id type="cpan-module">Net::XMPP::Namespaces</remote-id>
+ <remote-id type="cpan-module">Net::XMPP::Presence</remote-id>
+ <remote-id type="cpan-module">Net::XMPP::PrivacyLists</remote-id>
+ <remote-id type="cpan-module">Net::XMPP::Protocol</remote-id>
+ <remote-id type="cpan-module">Net::XMPP::Roster</remote-id>
+ <remote-id type="cpan-module">Net::XMPP::Stanza</remote-id>
+ </upstream>
+</pkgmetadata>