summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-11-24 17:15:01 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-11-24 17:18:38 +0100
commit72abb6e5464993d1ee25a1b69e478da65c9bb5fe (patch)
treef2a27554cb5756b21e42b4303ffda9b5fccc045d /dev-perl/Path-Iterator-Rule/Path-Iterator-Rule-1.15.0.ebuild
parentdev-perl/PAR-Dist: Remove old (diff)
downloadgentoo-72abb6e5464993d1ee25a1b69e478da65c9bb5fe.tar.gz
gentoo-72abb6e5464993d1ee25a1b69e478da65c9bb5fe.tar.bz2
gentoo-72abb6e5464993d1ee25a1b69e478da65c9bb5fe.zip
dev-perl/Path-Iterator-Rule: Version bump 1.015
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Path-Iterator-Rule/Path-Iterator-Rule-1.15.0.ebuild')
-rw-r--r--dev-perl/Path-Iterator-Rule/Path-Iterator-Rule-1.15.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-perl/Path-Iterator-Rule/Path-Iterator-Rule-1.15.0.ebuild b/dev-perl/Path-Iterator-Rule/Path-Iterator-Rule-1.15.0.ebuild
new file mode 100644
index 000000000000..06be0c85065e
--- /dev/null
+++ b/dev-perl/Path-Iterator-Rule/Path-Iterator-Rule-1.15.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=DAGOLDEN
+DIST_VERSION=1.015
+inherit perl-module
+
+DESCRIPTION="Iterative, recursive file finder"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="Apache-2.0"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-File-Spec
+ >=dev-perl/Number-Compare-0.20.0
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Text-Glob
+ dev-perl/Try-Tiny
+ virtual/perl-if
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.170.0
+ test? (
+ virtual/perl-Exporter
+ virtual/perl-File-Temp
+ dev-perl/File-pushd
+ dev-perl/Path-Tiny
+ dev-perl/Test-Deep
+ >=dev-perl/Test-Filename-0.30.0
+ >=virtual/perl-Test-Simple-0.920.0
+ virtual/perl-parent
+ )
+"