summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2023-12-02 20:14:30 +0200
committerSam James <sam@gentoo.org>2023-12-02 21:33:32 +0000
commit0d20638f9b8d8b07a3f825ec33fbb775bb89168f (patch)
treecfc2a6381d21aacbfe71ab1329b812f7bcc63ba7 /dev-perl/Search-Xapian
parentx11-misc/colord: fix usage of vala eclass in EAPI 8 (diff)
downloadgentoo-0d20638f9b8d8b07a3f825ec33fbb775bb89168f.tar.gz
gentoo-0d20638f9b8d8b07a3f825ec33fbb775bb89168f.tar.bz2
gentoo-0d20638f9b8d8b07a3f825ec33fbb775bb89168f.zip
dev-perl/Search-Xapian: inmemory use flag required in xapian
Cloess: https://github.com/gentoo/libressl/issues/545 Closes: https://bugs.gentoo.org/625658 Signed-off-by: Alfred Wingate <parona@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/34095 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/Search-Xapian')
-rw-r--r--dev-perl/Search-Xapian/Search-Xapian-1.2.25.5-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/Search-Xapian/Search-Xapian-1.2.25.5-r2.ebuild b/dev-perl/Search-Xapian/Search-Xapian-1.2.25.5-r2.ebuild
new file mode 100644
index 000000000000..9f7f612265b6
--- /dev/null
+++ b/dev-perl/Search-Xapian/Search-Xapian-1.2.25.5-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=OLLY
+inherit perl-module toolchain-funcs
+
+DESCRIPTION="Perl XS frontend to the Xapian C++ search library"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-libs/xapian-1.4:0=[inmemory]
+ !dev-libs/xapian-bindings[perl]"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( dev-perl/Devel-Leak )
+"
+
+DIST_TEST=do
+# parallel fails sometimes...
+
+src_configure() {
+ myconf="CXX=$(tc-getCXX) CXXFLAGS=${CXXFLAGS}"
+ perl-module_src_configure
+}
+
+src_install() {
+ perl-module_src_install
+
+ use examples && {
+ docinto examples
+ dodoc "${S}"/examples/*
+ }
+}