summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-12-11 05:26:06 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-12-11 05:33:25 +0100
commitd7ed4a7a1cfa96ae5637c8bc6e70ad54d7596ece (patch)
tree6821ed6ce14f91e65999e7066ebc4863c675d47a /dev-perl/Try-Tiny/Try-Tiny-0.310.0.ebuild
parentdev-perl/Tree-Simple: Remove old (diff)
downloadgentoo-d7ed4a7a1cfa96ae5637c8bc6e70ad54d7596ece.tar.gz
gentoo-d7ed4a7a1cfa96ae5637c8bc6e70ad54d7596ece.tar.bz2
gentoo-d7ed4a7a1cfa96ae5637c8bc6e70ad54d7596ece.zip
dev-perl/Try-Tiny: Version bump 0.31
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Try-Tiny/Try-Tiny-0.310.0.ebuild')
-rw-r--r--dev-perl/Try-Tiny/Try-Tiny-0.310.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-perl/Try-Tiny/Try-Tiny-0.310.0.ebuild b/dev-perl/Try-Tiny/Try-Tiny-0.310.0.ebuild
new file mode 100644
index 000000000000..6df86bef0af2
--- /dev/null
+++ b/dev-perl/Try-Tiny/Try-Tiny-0.310.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=ETHER
+DIST_VERSION=0.31
+inherit perl-module
+
+DESCRIPTION="Minimal try/catch with proper localization of \$@"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="minimal"
+
+RDEPEND="
+ !<=dev-perl/Try-Tiny-Except-0.10.0
+ !minimal? (
+ || ( >=virtual/perl-Scalar-List-Utils-1.400.0 dev-perl/Sub-Name )
+ )
+ virtual/perl-Carp
+ >=virtual/perl-Exporter-5.570.0
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ !minimal? (
+ >=virtual/perl-CPAN-Meta-2.120.900
+ >=dev-perl/Capture-Tiny-0.120.0
+ )
+ virtual/perl-File-Spec
+ virtual/perl-Test-Simple
+ virtual/perl-if
+ )
+"