summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-10-24 11:10:18 +0100
committerSam James <sam@gentoo.org>2024-10-24 11:22:26 +0100
commitd01edb158ac1ca1963212da662fa4a9476e448b9 (patch)
treef67edf6cdd80693603186b3c163ec01a0be5011d /dev-perl/XML-Compile
parentdev-perl/Future: add 0.510.0 (diff)
downloadgentoo-d01edb158ac1ca1963212da662fa4a9476e448b9.tar.gz
gentoo-d01edb158ac1ca1963212da662fa4a9476e448b9.tar.bz2
gentoo-d01edb158ac1ca1963212da662fa4a9476e448b9.zip
dev-perl/XML-Compile: add 1.640.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/XML-Compile')
-rw-r--r--dev-perl/XML-Compile/Manifest1
-rw-r--r--dev-perl/XML-Compile/XML-Compile-1.640.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-perl/XML-Compile/Manifest b/dev-perl/XML-Compile/Manifest
index 030d5c69a8ee..99ea227e585b 100644
--- a/dev-perl/XML-Compile/Manifest
+++ b/dev-perl/XML-Compile/Manifest
@@ -1 +1,2 @@
DIST XML-Compile-1.63.tar.gz 210240 BLAKE2B 24d912ecc779b66cc3cff208fbf13852ee362cb8ea4e04a987d7594956fcee0c9dab80a61cd04cddc134a7f1711b52c1396338f01447fbb66e674ff6227094cb SHA512 92f030ae7d54ef9aa82910e570d011cb98eda1546695a26626e5b17bfde7016d155f50ffe87fd4ae4111d075ad852d44fa7183ec96bf0c5cb2a7fba46a1a13db
+DIST XML-Compile-1.64.tar.gz 210685 BLAKE2B b294737ef12bc1d93d8f6108e79617eacc272f07b033e9d12a8f4a4726233983415f0e5db86b0a77ff0e03a98feaa39b0e87bbb07f8843b01926ac6a35a0e943 SHA512 61517b11de05b19018bc1231992856c13a2acccc5e69d9b15a8631f015837344f62cfc7076454a618f5eb6c768e3d70d8d32a22ee2e41829f928ba3fa538c5e9
diff --git a/dev-perl/XML-Compile/XML-Compile-1.640.0.ebuild b/dev-perl/XML-Compile/XML-Compile-1.640.0.ebuild
new file mode 100644
index 000000000000..ee4249941abc
--- /dev/null
+++ b/dev-perl/XML-Compile/XML-Compile-1.640.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=MARKOV
+DIST_VERSION=1.64
+inherit perl-module
+
+DESCRIPTION="Compilation based XML Processing"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=virtual/perl-Digest-MD5-2.360.0
+ >=virtual/perl-IO-1.220.0
+ virtual/perl-Scalar-List-Utils
+ >=dev-perl/Log-Report-1.200.0
+ >=virtual/perl-MIME-Base64-3.100.0
+ >=virtual/perl-Math-BigInt-1.770.0
+ >=virtual/perl-Math-BigRat-0.100.0
+ dev-perl/Types-Serialiser
+ >=dev-perl/XML-LibXML-2.10.700
+ >=virtual/perl-bignum-0.100.0
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=dev-perl/Test-Deep-0.95.0
+ >=virtual/perl-Test-Simple-0.540.0
+ >=dev-perl/XML-Compile-Tester-0.900.0
+ )
+"
+
+src_install() {
+ perl-module_src_install
+ dodoc -r html
+}