summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-22 18:46:23 +0100
committerSam James <sam@gentoo.org>2022-04-22 18:51:22 +0100
commit387e4ae026e0d3b3e0ae36316622e4a00eaa81e7 (patch)
tree45818963755275f3d9b196a74a982580c3cf32e4 /dev-perl/XML-Validator-Schema/XML-Validator-Schema-1.100.0-r2.ebuild
parentnet-mail/mu: add description for gnu-emacs maintainer (diff)
downloadgentoo-387e4ae026e0d3b3e0ae36316622e4a00eaa81e7.tar.gz
gentoo-387e4ae026e0d3b3e0ae36316622e4a00eaa81e7.tar.bz2
gentoo-387e4ae026e0d3b3e0ae36316622e4a00eaa81e7.zip
dev-perl/XML-Validator-Schema: depend on newer XML-Sax
Needed to avoid "miscompilation" (essentially empty install), as newer XML-Sax has the ROOT check fixed. Closes: https://bugs.gentoo.org/840053 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/XML-Validator-Schema/XML-Validator-Schema-1.100.0-r2.ebuild')
-rw-r--r--dev-perl/XML-Validator-Schema/XML-Validator-Schema-1.100.0-r2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-perl/XML-Validator-Schema/XML-Validator-Schema-1.100.0-r2.ebuild b/dev-perl/XML-Validator-Schema/XML-Validator-Schema-1.100.0-r2.ebuild
new file mode 100644
index 000000000000..12692f444b2e
--- /dev/null
+++ b/dev-perl/XML-Validator-Schema/XML-Validator-Schema-1.100.0-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=SAMTREGAR
+DIST_VERSION=1.10
+
+inherit perl-module
+
+DESCRIPTION="Validate XML against a subset of W3C XML Schema"
+
+SLOT="0"
+KEYWORDS="~amd64"
+
+# >= on XML-Sax needed to avoid "miscompilation" (essentially empty install), as newer XML-Sax
+# has the ROOT check fixed. Didn't happen with XML-SAX-Expat, but best to be careful.
+# bug #840053
+RDEPEND="
+ >=dev-perl/XML-SAX-1.20.0-r1
+ dev-perl/Tree-DAG_Node
+ dev-perl/XML-Filter-BufferText
+"
+BDEPEND="${RDEPEND}
+"