summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-04-25 15:40:00 -0400
committerBrian Evans <grknight@gentoo.org>2018-04-25 15:40:00 -0400
commitcfa7dd0e726345dcce77e2cb197b0f5f92af0dee (patch)
tree56bcf23391aee15b9ee13bcc9e1e3ad395fa887a /dev-php/doctrine/doctrine-2.6.1.ebuild
parentapp-office/texstudio: amd64 stable wrt bug #654040 (diff)
downloadgentoo-cfa7dd0e726345dcce77e2cb197b0f5f92af0dee.tar.gz
gentoo-cfa7dd0e726345dcce77e2cb197b0f5f92af0dee.tar.bz2
gentoo-cfa7dd0e726345dcce77e2cb197b0f5f92af0dee.zip
dev-php/doctrine: Version bump; requires PHP 7.1+
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'dev-php/doctrine/doctrine-2.6.1.ebuild')
-rw-r--r--dev-php/doctrine/doctrine-2.6.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-php/doctrine/doctrine-2.6.1.ebuild b/dev-php/doctrine/doctrine-2.6.1.ebuild
new file mode 100644
index 000000000000..c716c1274c2c
--- /dev/null
+++ b/dev-php/doctrine/doctrine-2.6.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P="${PN}2-${PV}"
+DESCRIPTION="An object relational mapper for PHP"
+HOMEPAGE="http://www.doctrine-project.org/"
+SRC_URI="https://github.com/${PN}/${PN}2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/php-7.1:*[cli,pdo]"
+DEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/share/php
+ doins -r lib/Doctrine
+ insinto /usr/share/php/Doctrine
+ exeinto /usr/share/php/Doctrine
+ doins bin/doctrine.php
+ doexe bin/doctrine
+ dosym ../share/php/Doctrine/doctrine /usr/bin/doctrine
+}