summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/igbinary
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/igbinary')
-rw-r--r--dev-php/igbinary/Manifest1
-rw-r--r--dev-php/igbinary/files/zts-fix.patch44
-rw-r--r--dev-php/igbinary/igbinary-1.2.1.ebuild38
-rw-r--r--dev-php/igbinary/metadata.xml8
4 files changed, 91 insertions, 0 deletions
diff --git a/dev-php/igbinary/Manifest b/dev-php/igbinary/Manifest
new file mode 100644
index 000000000000..8a6daf1a64ce
--- /dev/null
+++ b/dev-php/igbinary/Manifest
@@ -0,0 +1 @@
+DIST igbinary-1.2.1.tar.gz 143092 SHA256 f71a2e085669ed915740b29f55b6a81e30bae52215d041938afb9212e6bafc27 SHA512 5e69831606cfe47db2ae2b2200bd8bcfce42db32599a2a58cf23238d88896a2ef79baf16e78b3aaefb8725f8fdd7b815470e2d314ba14ea05f33be547da31777 WHIRLPOOL f7eb5d28b536bd1d2b0565f3e8541cbdb39edd2f5130bd041f0d75cc8218edeaa8719ebaea4d8ddf372172df9863d9d72a12dd8fc09c3653418b49e26d0e2f61
diff --git a/dev-php/igbinary/files/zts-fix.patch b/dev-php/igbinary/files/zts-fix.patch
new file mode 100644
index 000000000000..3de9b49f441e
--- /dev/null
+++ b/dev-php/igbinary/files/zts-fix.patch
@@ -0,0 +1,44 @@
+--- a/apc_serializer.h
++++ b/apc_serializer.h
+@@ -32,29 +32,37 @@
+ typedef int (*apc_serialize_t)(APC_SERIALIZER_ARGS);
+ typedef int (*apc_unserialize_t)(APC_UNSERIALIZER_ARGS);
+
+-typedef int (*apc_register_serializer_t)(const char* name,
+- apc_serialize_t serialize,
++typedef int (*apc_register_serializer_t)(const char* name,
++ apc_serialize_t serialize,
+ apc_unserialize_t unserialize,
+ void *config TSRMLS_DC);
+
+ /*
+ * ABI version for constant hooks. Increment this any time you make any changes
+ * to any function in this file.
+ */
+ #define APC_SERIALIZER_ABI "0"
+ #define APC_SERIALIZER_CONSTANT "\000apc_register_serializer-" APC_SERIALIZER_ABI
+
+-static int apc_register_serializer(const char* name,
++#if !defined(APC_UNUSED)
++# if defined(__GNUC__)
++# define APC_UNUSED __attribute__((unused))
++# else
++# define APC_UNUSED
++# endif
++#endif
++
++static APC_UNUSED int apc_register_serializer(const char* name,
+ apc_serialize_t serialize,
+ apc_unserialize_t unserialize,
+ void *config TSRMLS_DC)
+ {
+ zval *apc_magic_constant = NULL;
+ (void)config;
+
+ ALLOC_INIT_ZVAL(apc_magic_constant);
+
+- if (zend_get_constant(APC_SERIALIZER_CONSTANT, sizeof(APC_SERIALIZER_CONSTANT)-1, apc_magic_constant)) {
++ if (zend_get_constant(APC_SERIALIZER_CONSTANT, sizeof(APC_SERIALIZER_CONSTANT)-1, apc_magic_constant TSRMLS_CC)) {
+ if(apc_magic_constant) {
+ apc_register_serializer_t register_func = (apc_register_serializer_t)(Z_LVAL_P(apc_magic_constant));
+ if(register_func) {
diff --git a/dev-php/igbinary/igbinary-1.2.1.ebuild b/dev-php/igbinary/igbinary-1.2.1.ebuild
new file mode 100644
index 000000000000..2bd558fe06d9
--- /dev/null
+++ b/dev-php/igbinary/igbinary-1.2.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PHP_EXT_NAME="igbinary"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="README"
+
+USE_PHP="php5-6 php5-5 php5-4"
+
+inherit php-ext-source-r2
+
+KEYWORDS="amd64 x86"
+
+DESCRIPTION="A fast drop in replacement for the standard PHP serialize"
+HOMEPAGE="https://github.com/igbinary/igbinary"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${PF}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ my_conf="--enable-igbinary"
+ php-ext-source-r2_src_configure
+}
+
+src_test() {
+ for slot in $(php_get_slots); do
+ php_init_slot_env ${slot}
+ NO_INTERACTION="yes" emake test || die "emake test failed for slot ${slot}"
+ done
+}
diff --git a/dev-php/igbinary/metadata.xml b/dev-php/igbinary/metadata.xml
new file mode 100644
index 000000000000..ed3ed4256f63
--- /dev/null
+++ b/dev-php/igbinary/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+ <upstream>
+ <remote-id type="github">igbinary/igbinary</remote-id>
+ </upstream>
+</pkgmetadata>