summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2022-03-18 12:22:39 -0400
committerBrian Evans <grknight@gentoo.org>2022-03-18 12:53:26 -0400
commit303d21c35dca67e6c623124f908dd788552f6dc4 (patch)
treecc75be829cfd5b438e6c8da0a10adbe43a97a877 /dev-php/libvirt-php
parentdev-php/xhprof: Drop old; adjust targets (diff)
downloadgentoo-303d21c35dca67e6c623124f908dd788552f6dc4.tar.gz
gentoo-303d21c35dca67e6c623124f908dd788552f6dc4.tar.bz2
gentoo-303d21c35dca67e6c623124f908dd788552f6dc4.zip
dev-php/libvirt-php: Add new snapshot build
Needs further testing before restoring keywords Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php/libvirt-php')
-rw-r--r--dev-php/libvirt-php/Manifest1
-rw-r--r--dev-php/libvirt-php/libvirt-php-0.5.5_p20211020.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-php/libvirt-php/Manifest b/dev-php/libvirt-php/Manifest
index 60732c621d5d..560eb6a12413 100644
--- a/dev-php/libvirt-php/Manifest
+++ b/dev-php/libvirt-php/Manifest
@@ -1 +1,2 @@
DIST libvirt-php-0.5.5.tar.gz 761250 BLAKE2B 9899d2f0e5ea387333decce5071afc81d4160d54ef570dcbe04422dc3e93479ee57520f9bf33a0275ee86cd4b1c87e5a3f7d5118e0cd87658faed44d2ccd4807 SHA512 2ea263561a0bf5d155314e06dcf3c3b5c278640bc5edfa674cdd777cb6d0810bda0492c6cf77a02bc88fb6aa99b0ff1f0cbaeea87ff2e45bff9b5774a2507684
+DIST libvirt-php-0.5.5_p20211020.tar.bz2 359477 BLAKE2B f4be3cf138364997911b58b07e128e4b5c9e6f1520d876b51466a30cd2ade4035a06488e07b8be4cce65b1bc6585b768997214c9d0ba72cc51855b4fc0827ff4 SHA512 b935c910e8754000de45e88f5d5e61e2e95fbb1b007f0d747bf4cd3531ee9cb0ff5bc2ec6f561c79711df9b70e1c4cdaf2e046774341d29d3f2382d27ab8c494
diff --git a/dev-php/libvirt-php/libvirt-php-0.5.5_p20211020.ebuild b/dev-php/libvirt-php/libvirt-php-0.5.5_p20211020.ebuild
new file mode 100644
index 000000000000..8e019aab4abe
--- /dev/null
+++ b/dev-php/libvirt-php/libvirt-php-0.5.5_p20211020.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+PHP_EXT_NAME="libvirt-php"
+PHP_EXT_SKIP_PHPIZE="yes"
+USE_PHP="php7-4 php8-0 php8-1"
+PHP_EXT_ECONF_ARGS=()
+SNAPSHOT="23dde4ddc42fabee0b8c6625b80183b3cbe96a67"
+
+inherit php-ext-source-r3 autotools
+
+DESCRIPTION="PHP bindings for libvirt"
+HOMEPAGE="http://libvirt.org/php/"
+SRC_URI="https://gitlab.com/libvirt/${PN}/-/archive/${SNAPSHOT}/${PN}-${SNAPSHOT}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS=""
+IUSE="doc"
+
+RDEPEND="app-emulation/libvirt
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ virtual/pkgconfig
+ doc? ( app-text/xhtml1 )"
+
+S="${WORKDIR}/${PN}-${SNAPSHOT}"
+PHP_EXT_S="${S}"
+
+DOCS=( ChangeLog NEWS README )
+# Remove the insane check for pecl-imagick which is only used in examples
+# and is not called upon in any build
+PATCHES=( "${FILESDIR}/remove-imagick-check.patch" )
+
+src_unpack() {
+ default
+
+ # create the default modules directory to be able
+ # to use the php-ext-source-r3 eclass to configure/build
+ ln -s src "${S}/modules" || die
+}
+
+src_prepare() {
+ php-ext-source-r3_src_prepare
+
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env "${slot}"
+ eautoreconf
+ done
+}
+
+src_install() {
+ local slot
+ for slot in $(php_get_slots); do
+ php_init_slot_env ${slot}
+ insinto "${EXT_DIR}"
+ doins "src/.libs/${PHP_EXT_NAME}.so"
+ done
+
+ php-ext-source-r3_createinifiles
+ einstalldocs
+
+ if use doc ; then
+ docinto html
+ dodoc -r docs/*
+ fi
+}
+
+src_test() {
+ for slot in $(php_get_slots); do
+ php_init_slot_env ${slot}
+ default
+ done
+}