summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2016-11-28 15:55:39 -0500
committerBrian Evans <grknight@gentoo.org>2016-11-28 15:57:36 -0500
commit93234aea3d6e645fe5294265c8cb3db594cff2ea (patch)
tree055c37dd546f3ac78fe9642edaf600f1ed7562d4 /dev-php/pecl-htscanner
parentdev-php/pecl-haru: Drop old (diff)
downloadgentoo-93234aea3d6e645fe5294265c8cb3db594cff2ea.tar.gz
gentoo-93234aea3d6e645fe5294265c8cb3db594cff2ea.tar.bz2
gentoo-93234aea3d6e645fe5294265c8cb3db594cff2ea.zip
dev-php/pecl-htscanner: Revbump to drop php 5.4 and 5.5 dependencies
This package has not been ported and fails with PHP 7.0. Patches are welcome, but this package is in danger of being dropped when PHP 5.6 becomes obsolete. Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-php/pecl-htscanner')
-rw-r--r--dev-php/pecl-htscanner/pecl-htscanner-1.0.1-r3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-php/pecl-htscanner/pecl-htscanner-1.0.1-r3.ebuild b/dev-php/pecl-htscanner/pecl-htscanner-1.0.1-r3.ebuild
new file mode 100644
index 000000000000..6a00777fc25b
--- /dev/null
+++ b/dev-php/pecl-htscanner/pecl-htscanner-1.0.1-r3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PHP_EXT_NAME="htscanner"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="README"
+PHP_EXT_SAPIS="cgi"
+
+USE_PHP="php5-6"
+
+inherit php-ext-pecl-r3
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Enables .htaccess options for php-scripts running as cgi"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE=""
+
+for target in ${USE_PHP}; do
+ slot=${target/php}
+ slot=${slot/-/.}
+ PHPUSEDEPEND="${PHPUSEDEPEND}
+ php_targets_${target}? ( dev-lang/php:${slot}[cgi] )"
+done
+
+DEPEND="${PHPUSEDEPEND}"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ php-ext-pecl-r3_src_install
+
+ php-ext-source-r3_addtoinifiles "config_file" ".htaccess"
+ php-ext-source-r3_addtoinifiles "default_docroot" "/"
+ php-ext-source-r3_addtoinifiles "default_ttl" "300"
+ php-ext-source-r3_addtoinifiles "stop_on_error" "0"
+}