summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-09-05 15:42:01 +0200
committerDavid Seifert <soap@gentoo.org>2023-09-05 15:42:01 +0200
commit46e67d857af092a0a3df98d4aec54529b4b5a264 (patch)
treefcaff70c3054e1dcab106bfdd87719dca6672b4d /dev-php/pecl-memcache
parentmedia-fonts/iosevka: add 26.3.2 (diff)
downloadgentoo-46e67d857af092a0a3df98d4aec54529b4b5a264.tar.gz
gentoo-46e67d857af092a0a3df98d4aec54529b4b5a264.tar.bz2
gentoo-46e67d857af092a0a3df98d4aec54529b4b5a264.zip
dev-php/*: remote obsolete PHP targets 'php7-2' and 'php7-3'
Closes: https://github.com/gentoo/gentoo/pull/32627 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-php/pecl-memcache')
-rw-r--r--dev-php/pecl-memcache/pecl-memcache-4.0.5.2-r1.ebuild14
-rw-r--r--dev-php/pecl-memcache/pecl-memcache-8.0-r1.ebuild5
-rw-r--r--dev-php/pecl-memcache/pecl-memcache-8.0.ebuild5
3 files changed, 11 insertions, 13 deletions
diff --git a/dev-php/pecl-memcache/pecl-memcache-4.0.5.2-r1.ebuild b/dev-php/pecl-memcache/pecl-memcache-4.0.5.2-r1.ebuild
index 240a4d9d5754..da8213cc9cdc 100644
--- a/dev-php/pecl-memcache/pecl-memcache-4.0.5.2-r1.ebuild
+++ b/dev-php/pecl-memcache/pecl-memcache-4.0.5.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -9,11 +9,11 @@ PHP_EXT_NEEDED_USE="session(-)?"
DOCS=( README example.php )
HTML_DOCS=( memcache.php )
-USE_PHP="php7-3 php7-4 php8-0 php8-1"
+USE_PHP="php7-4 php8-0 php8-1"
inherit php-ext-pecl-r3
-USE_PHP="php7-3 php7-4"
+USE_PHP="php7-4"
KEYWORDS="~amd64 ~hppa ~ppc64 ~x86"
@@ -22,7 +22,7 @@ LICENSE="PHP-3"
SLOT="7"
IUSE="+session"
-DEPEND="php_targets_php7-3? ( sys-libs/zlib ) php_targets_php7-4? ( sys-libs/zlib )"
+DEPEND="php_targets_php7-4? ( sys-libs/zlib )"
RDEPEND="${DEPEND}
php_targets_php8-0? ( dev-php/pecl-memcache:8[php_targets_php8-0(-)?] )
php_targets_php8-1? ( dev-php/pecl-memcache:8[php_targets_php8-1(-)?] )
@@ -32,7 +32,7 @@ RDEPEND="${DEPEND}
RESTRICT='test'
src_prepare() {
- if use php_targets_php7-3 || use php_targets_php7-4 ; then
+ if use php_targets_php7-4 ; then
php-ext-source-r3_src_prepare
else
default
@@ -40,14 +40,14 @@ src_prepare() {
}
src_configure() {
- if use php_targets_php7-3 || use php_targets_php7-4 ; then
+ if use php_targets_php7-4 ; then
local PHP_EXT_ECONF_ARGS=( --enable-memcache --with-zlib-dir="${EPREFIX}/usr" $(use_enable session memcache-session) )
php-ext-source-r3_src_configure
fi
}
src_install() {
- if use php_targets_php7-3 || use php_targets_php7-4 ; then
+ if use php_targets_php7-4 ; then
php-ext-pecl-r3_src_install
php-ext-source-r3_addtoinifiles "memcache.allow_failover" "true"
diff --git a/dev-php/pecl-memcache/pecl-memcache-8.0-r1.ebuild b/dev-php/pecl-memcache/pecl-memcache-8.0-r1.ebuild
index ec0fa315424c..fc0048196784 100644
--- a/dev-php/pecl-memcache/pecl-memcache-8.0-r1.ebuild
+++ b/dev-php/pecl-memcache/pecl-memcache-8.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -9,7 +9,7 @@ PHP_EXT_NEEDED_USE="session(-)?"
DOCS=( README example.php )
HTML_DOCS=( memcache.php )
-USE_PHP="php7-3 php7-4 php8-0 php8-1"
+USE_PHP="php7-4 php8-0 php8-1"
inherit php-ext-pecl-r3
@@ -27,7 +27,6 @@ DEPEND="
php_targets_php8-1? ( sys-libs/zlib )
"
RDEPEND="${DEPEND}
- php_targets_php7-3? ( dev-php/pecl-memcache:7[php_targets_php7-3(-)?] )
php_targets_php7-4? ( dev-php/pecl-memcache:7[php_targets_php7-4(-)?] )
"
diff --git a/dev-php/pecl-memcache/pecl-memcache-8.0.ebuild b/dev-php/pecl-memcache/pecl-memcache-8.0.ebuild
index a837166eaa5c..7d51a942b070 100644
--- a/dev-php/pecl-memcache/pecl-memcache-8.0.ebuild
+++ b/dev-php/pecl-memcache/pecl-memcache-8.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -9,7 +9,7 @@ PHP_EXT_NEEDED_USE="session(-)?"
DOCS=( README example.php )
HTML_DOCS=( memcache.php )
-USE_PHP="php7-3 php7-4 php8-0"
+USE_PHP="php7-4 php8-0"
inherit php-ext-pecl-r3
@@ -24,7 +24,6 @@ IUSE="+session"
DEPEND="php_targets_php8-0? ( sys-libs/zlib )"
RDEPEND="${DEPEND}
- php_targets_php7-3? ( dev-php/pecl-memcache:7[php_targets_php7-3(-)?] )
php_targets_php7-4? ( dev-php/pecl-memcache:7[php_targets_php7-4(-)?] )
"