summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/pecl-stomp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/pecl-stomp')
-rw-r--r--dev-php/pecl-stomp/Manifest1
-rw-r--r--dev-php/pecl-stomp/metadata.xml5
-rw-r--r--dev-php/pecl-stomp/pecl-stomp-1.0.6.ebuild39
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-php/pecl-stomp/Manifest b/dev-php/pecl-stomp/Manifest
new file mode 100644
index 000000000000..e6c7570f95d2
--- /dev/null
+++ b/dev-php/pecl-stomp/Manifest
@@ -0,0 +1 @@
+DIST stomp-1.0.6.tgz 20052 SHA256 79bf86542a167134fc9b264c90d811c06bed7ec52cdefc36e44ff933dd7d0918 SHA512 0ad521f759bdc64ef50a7d81fb1c289aae466edd605a9f5f916d104a255caf1685c60687b7582608d3fe48ea321f4975d2c7d950d6de35a28b4ec0f99c4d9c50 WHIRLPOOL 1f0fcac0ed7fd76c7e4aa832a8326ce8e0d8f8b97aba6345bf87f6e7f3f96aa1638d22eddc6996b12c97a66c3fe60422f58c032e186d6d58ab96d4fbab4ae608
diff --git a/dev-php/pecl-stomp/metadata.xml b/dev-php/pecl-stomp/metadata.xml
new file mode 100644
index 000000000000..fd3dbe39fa64
--- /dev/null
+++ b/dev-php/pecl-stomp/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+</pkgmetadata>
diff --git a/dev-php/pecl-stomp/pecl-stomp-1.0.6.ebuild b/dev-php/pecl-stomp/pecl-stomp-1.0.6.ebuild
new file mode 100644
index 000000000000..ae57b89d77a0
--- /dev/null
+++ b/dev-php/pecl-stomp/pecl-stomp-1.0.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+USE_PHP="php5-4 php5-5 php5-6"
+PHP_EXT_NAME="stomp"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="CREDITS EXPERIMENTAL README"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="PHP extension to communicate with any Stomp compliant Message Brokers"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE="+ssl"
+
+for target in ${USE_PHP}; do
+ slot=${target/php}
+ slot=${slot/-/.}
+ PHPUSEDEPEND="${PHPUSEDEPEND}
+ php_targets_${target}? ( dev-lang/php:${slot}[ssl?] )"
+done
+
+DEPEND="${DEPEND}
+ ${PHPUSEDEPEND}
+"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ my_conf="--enable-stomp
+ $(use_with ssl openssl-dir=/usr)"
+ php-ext-pecl-r2_src_compile
+}