summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2024-11-18 13:21:24 +0000
committerSam James <sam@gentoo.org>2024-11-25 00:01:47 +0000
commit36606ef410c6434a6604a47c64dc92d0df9226a6 (patch)
treeaa3225b869d907f419c93c078a3bdddbc843e06c /dev-php
parentdev-util/sccache: format metadata.xml (diff)
downloadgentoo-36606ef410c6434a6604a47c64dc92d0df9226a6.tar.gz
gentoo-36606ef410c6434a6604a47c64dc92d0df9226a6.tar.bz2
gentoo-36606ef410c6434a6604a47c64dc92d0df9226a6.zip
dev-php/pecl-ssh2: add 1.4.1
Bug: https://bugs.gentoo.org/943650 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-ssh2/Manifest1
-rw-r--r--dev-php/pecl-ssh2/pecl-ssh2-1.4.1.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-php/pecl-ssh2/Manifest b/dev-php/pecl-ssh2/Manifest
index 0d800ebf183e..e8486cbe1dd7 100644
--- a/dev-php/pecl-ssh2/Manifest
+++ b/dev-php/pecl-ssh2/Manifest
@@ -1 +1,2 @@
DIST ssh2-1.3.1.tgz 33838 BLAKE2B 05976ad143563fd9d51be3f8e23b5b22099e351d6f252b612aa1dcb56648dc337b623d2cddf7b9079f3e07c879ca69215a1987cd6f4326f97ba134e13c6d28e7 SHA512 c74d4f699853148b53cdca0eaf8837bfdbdd21d185761606acadf2442e84dbefdb00cde207e0ce4794ae1e4f8692a38ed903b6d11fdc57bca7b54a4250da9a76
+DIST ssh2-1.4.1.tgz 34265 BLAKE2B 5cd257de7f3b2408f696d4acc463b981ca691f1a10a175e028beb77bf044640e1bfa2c85b1731096af398ae9920bf05f73e383db6c3f9e0c30e38a008ce70278 SHA512 9ff90b95b8fabfa2a75cf8a62a55e93df19d3e952f79234fc1d7ef3a030089f8b3703412bf6e22d85c7bf5825cf8493a4d97ad51a1600185d3d16f81c72e155c
diff --git a/dev-php/pecl-ssh2/pecl-ssh2-1.4.1.ebuild b/dev-php/pecl-ssh2/pecl-ssh2-1.4.1.ebuild
new file mode 100644
index 000000000000..f5d84cb102d4
--- /dev/null
+++ b/dev-php/pecl-ssh2/pecl-ssh2-1.4.1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+PHP_EXT_NAME="ssh2"
+
+USE_PHP="php8-2 php8-3"
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="PHP bindings for the libssh2 library"
+HOMEPAGE="https://pecl.php.net/package/ssh2"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# Upstream notes say there are errors with gcrypt backend
+DEPEND=">=net-libs/libssh2-1.2[-gcrypt]"
+RDEPEND="${DEPEND}"