summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Schultz <mattsch@gmail.com>2024-12-11 09:31:59 -0600
committerSam James <sam@gentoo.org>2024-12-12 04:23:51 +0000
commit73e247edb11e13ed744cbd65a915b59fdc827cda (patch)
treec6e7d60fdc777aafedfc8f7a913d8108da218645 /dev-php
parentdev-php/pecl-raphf: update EAPI 7 -> 8 and added support for php 8.2 and higher. (diff)
downloadgentoo-73e247edb11e13ed744cbd65a915b59fdc827cda.tar.gz
gentoo-73e247edb11e13ed744cbd65a915b59fdc827cda.tar.bz2
gentoo-73e247edb11e13ed744cbd65a915b59fdc827cda.zip
dev-php/pecl-http: add 4.2.6, drop 4.2.2-r1
Closes: https://bugs.gentoo.org/945977 Signed-off-by: Matthew Schultz <mattsch@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/39682 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-http/Manifest2
-rw-r--r--dev-php/pecl-http/pecl-http-4.2.6.ebuild (renamed from dev-php/pecl-http/pecl-http-4.2.2-r1.ebuild)11
2 files changed, 7 insertions, 6 deletions
diff --git a/dev-php/pecl-http/Manifest b/dev-php/pecl-http/Manifest
index c6ecbe7266f4..cd0e425a2ea3 100644
--- a/dev-php/pecl-http/Manifest
+++ b/dev-php/pecl-http/Manifest
@@ -1 +1 @@
-DIST pecl_http-4.2.2.tgz 224436 BLAKE2B 26ef3bb38778f0374938ba3f3bddba37c3a2044c7b9ffe2aacbca2566251d26d37882bf66773b8ed62d46855e8f14ad9b577cdb1ef3db9eba9850c0b30e57284 SHA512 1203367d590c7d80ffe7a21e7ac352ba053e3daeb778bf99e08fc13582e665e1429f850e51e36304bdec15e6646b648f2c444b46fa263e5441d008ac41a00f4b
+DIST pecl_http-4.2.6.tgz 225503 BLAKE2B 834c5a38de2ec5525472fbe3a2c92804e3d471cdbd2f0791990bbde3001a4ba63822e9e4600b1a692f117f4fb941c86a78cd533512b7c5cacdad87f055160cfd SHA512 50c921d11e035281bd55152e449ee47d203c839d654b097fcbc5d6d93faf91a6111817b8a7157715de0af9f15c713974a53a2ab318eddd840bc3a7e6b2b50e11
diff --git a/dev-php/pecl-http/pecl-http-4.2.2-r1.ebuild b/dev-php/pecl-http/pecl-http-4.2.6.ebuild
index 976d95d6c8fa..3a022e4ce80a 100644
--- a/dev-php/pecl-http/pecl-http-4.2.2-r1.ebuild
+++ b/dev-php/pecl-http/pecl-http-4.2.6.ebuild
@@ -9,27 +9,28 @@ PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
PHP_INI_NAME="50-http"
-USE_PHP="php8-1"
+USE_PHP="php8-1 php8-2 php8-3"
inherit php-ext-pecl-r3
-KEYWORDS="amd64 x86"
-
DESCRIPTION="Extended HTTP Support for PHP"
LICENSE="BSD-2 MIT"
SLOT="8"
+KEYWORDS="~amd64 ~x86"
IUSE="ssl curl_ssl_gnutls +curl_ssl_openssl"
COMMON_DEPEND="app-arch/brotli:=
dev-libs/libevent
- >=dev-php/pecl-raphf-2.0.1:7[php_targets_php8-1(-)?]
+ >=dev-php/pecl-raphf-2.0.1:7[php_targets_php8-1(-)?,php_targets_php8-2(-)?,php_targets_php8-3(-)?]
net-dns/libidn2
sys-libs/zlib
ssl? ( net-misc/curl[ssl,curl_ssl_gnutls(-)=,curl_ssl_openssl(-)=] )
!ssl? ( net-misc/curl[-ssl] )
"
DEPEND="
- php_targets_php8-1? ( ${COMMON_DEPEND} dev-lang/php:8.1[session(-),iconv(-)] )"
+ php_targets_php8-1? ( ${COMMON_DEPEND} dev-lang/php:8.1[session(-),iconv(-)] )
+ php_targets_php8-2? ( ${COMMON_DEPEND} dev-lang/php:8.2[session(-),iconv(-)] )
+ php_targets_php8-3? ( ${COMMON_DEPEND} dev-lang/php:8.3[session(-),iconv(-)] )"
RDEPEND="${DEPEND}"
PHP_EXT_ECONF_ARGS=( --with-http --without-http-shared-deps