summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2021-01-21 13:07:22 -0500
committerBrian Evans <grknight@gentoo.org>2021-01-21 13:08:54 -0500
commitf834322b238f03bf6150626906c469578c901dd2 (patch)
tree4a0829a37a9eba6cd7eb86904673be2f0f326789 /dev-php
parentdev-python/snowballstemmer: Bump to 2.1.0 (diff)
downloadgentoo-f834322b238f03bf6150626906c469578c901dd2.tar.gz
gentoo-f834322b238f03bf6150626906c469578c901dd2.tar.bz2
gentoo-f834322b238f03bf6150626906c469578c901dd2.zip
dev-php/libvirt-php: Update live ebuild
PHP 8 is broken until upstream fixes things Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/libvirt-php/libvirt-php-9999.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/dev-php/libvirt-php/libvirt-php-9999.ebuild b/dev-php/libvirt-php/libvirt-php-9999.ebuild
index 2963ecd32d73..395c151a9cef 100644
--- a/dev-php/libvirt-php/libvirt-php-9999.ebuild
+++ b/dev-php/libvirt-php/libvirt-php-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
PHP_EXT_NAME="libvirt-php"
PHP_EXT_SKIP_PHPIZE="yes"
-USE_PHP="php5-6 php7-0 php7-1 php7-2 php7-3"
+USE_PHP="php7-3 php7-4"
PHP_EXT_ECONF_ARGS=()
inherit php-ext-source-r3 git-r3 autotools
@@ -26,7 +26,6 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
doc? ( app-text/xhtml1 )"
-RESTRICT="test"
DOCS=( ChangeLog NEWS README )
# Remove the insane check for pecl-imagick which is only used in examples
# and is not called upon in any build
@@ -63,3 +62,10 @@ src_install() {
dodoc -r docs/*
fi
}
+
+src_test() {
+ for slot in $(php_get_slots); do
+ php_init_slot_env ${slot}
+ default
+ done
+}