summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-25 08:42:00 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-25 09:09:28 +0100
commit2908591a7e5367c6e777ad87bb4d70f0598c4176 (patch)
tree8f09e1c97aec058cba5399ea05c3fe6645e660a3 /dev-python/Pyro4
parentdev-python/python-dbusmock: Bump to 0.25.0 (diff)
downloadgentoo-2908591a7e5367c6e777ad87bb4d70f0598c4176.tar.gz
gentoo-2908591a7e5367c6e777ad87bb4d70f0598c4176.tar.bz2
gentoo-2908591a7e5367c6e777ad87bb4d70f0598c4176.zip
dev-python/Pyro4: Bump to 4.82
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/Pyro4')
-rw-r--r--dev-python/Pyro4/Manifest1
-rw-r--r--dev-python/Pyro4/Pyro4-4.82.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/Pyro4/Manifest b/dev-python/Pyro4/Manifest
index 2399196aa57b..60c9c11e2489 100644
--- a/dev-python/Pyro4/Manifest
+++ b/dev-python/Pyro4/Manifest
@@ -1 +1,2 @@
DIST Pyro4-4.81.tar.gz 514678 BLAKE2B ffe9edcb947203b37cf1b13b2380f2b7d76357a5bca36e454fe67f6bd0d34574f5df429dd784ba2c2bc69c0188edd14e4572f12f5c137d87d2898f01ea3e855c SHA512 3848d473acd624ae1356ad3470c669eb0bc30287691ff8b9fc27fb0591ba305812c6be1946d6a2a91377e222a9e114f05ed18170d1b035dec24e436ab8dadc59
+DIST Pyro4-4.82.tar.gz 516110 BLAKE2B ecd7b5cf1469896acfec1db92d99784aa316db5cadbb7fc595a5f9916ac705619d070771549fb8ba7379a7395e4449eabcfc84aa131d4b23b587b7467f4bf196 SHA512 f5916ce37ec52d8cd23bece79325480140621ac8412febb4877a32b1ce54502ef17d20bf591dc30eb20e9619741548b30a78165937d5e69e8d1911d95a23b1e1
diff --git a/dev-python/Pyro4/Pyro4-4.82.ebuild b/dev-python/Pyro4/Pyro4-4.82.ebuild
new file mode 100644
index 000000000000..4d1a73752e5c
--- /dev/null
+++ b/dev-python/Pyro4/Pyro4-4.82.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Distributed object middleware for Python (RPC)"
+HOMEPAGE="https://pypi.org/project/Pyro4/
+ https://github.com/irmen/Pyro4"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/serpent-1.27[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/cloudpickle-1.2.1[${PYTHON_USEDEP}]
+ >=dev-python/dill-0.2.6[${PYTHON_USEDEP}]
+ >=dev-python/msgpack-0.5.2[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ # Disable tests requiring network connection.
+ rm tests/PyroTests/test_naming.py || die
+ sed \
+ -e "s/testStartNSfunc/_&/" \
+ -i tests/PyroTests/test_naming2.py || die
+
+ sed \
+ -e "s/testBroadcast/_&/" \
+ -e "s/testGetIP/_&/" \
+ -i tests/PyroTests/test_socket.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/. )
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}