summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-01-06 07:09:33 +0100
committerMichał Górny <mgorny@gentoo.org>2025-01-06 07:39:36 +0100
commit1a5bfb1c1fe90eb394e978d03f4f7cee2c315eeb (patch)
treed779dc7934a45ccb6f44d7206d87433d0362b7c4 /dev-python/a2wsgi
parentdev-python/ensurepip-setuptools: Bump to 75.7.0 (diff)
downloadgentoo-1a5bfb1c1fe90eb394e978d03f4f7cee2c315eeb.tar.gz
gentoo-1a5bfb1c1fe90eb394e978d03f4f7cee2c315eeb.tar.bz2
gentoo-1a5bfb1c1fe90eb394e978d03f4f7cee2c315eeb.zip
dev-python/a2wsgi: Bump to 1.10.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/a2wsgi')
-rw-r--r--dev-python/a2wsgi/Manifest1
-rw-r--r--dev-python/a2wsgi/a2wsgi-1.10.8.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/a2wsgi/Manifest b/dev-python/a2wsgi/Manifest
index c0e8002a0c22..2f3d7002cfa5 100644
--- a/dev-python/a2wsgi/Manifest
+++ b/dev-python/a2wsgi/Manifest
@@ -1 +1,2 @@
DIST a2wsgi-1.10.7.tar.gz 18669 BLAKE2B a29f294cd3d31ad3859d190a2e187bbb0b667fe6d29068793163aa0cf6429ff03fc408613c772c5efcbb1c961820664304c118f1036e4c9c567fc3e06ce55214 SHA512 49075f6cac08f1a5ae3e4ac1d1510a33394912e7e973771b8db2643792e7d875daa1db9e87a69062697cd3001533ddb7e13388edf4d963cd23f5bb84db141095
+DIST a2wsgi-1.10.8.tar.gz 18729 BLAKE2B d36614cdf66680240c49f142208d9cbad660117bfd160f37606bf67ecc7dd7178f63bf7685669b1207bcfb417568807449b49e8ef85d3b8642da0c199211686a SHA512 b8ed1d1370af6ba13339fa408e4da575cbb3229346a67a8c270207038b739daee341d1755c5db0e7b690f4a8654f54113e0c6f9a99ff359634c663e6df86e0ae
diff --git a/dev-python/a2wsgi/a2wsgi-1.10.8.ebuild b/dev-python/a2wsgi/a2wsgi-1.10.8.ebuild
new file mode 100644
index 000000000000..6fd945ac9a2e
--- /dev/null
+++ b/dev-python/a2wsgi/a2wsgi-1.10.8.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2023-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Convert WSGI app to ASGI app or ASGI app to WSGI app"
+HOMEPAGE="
+ https://github.com/abersheeran/a2wsgi/
+ https://pypi.org/project/a2wsgi/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ <dev-python/httpx-1[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.22.0[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/starlette[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires baize
+ tests/test_asgi.py::test_baize_stream_response
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio
+}