summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-30 04:25:42 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-30 04:25:42 +0200
commiteafc6ca65f77b7c4bae087c32ddd14325fd68633 (patch)
tree99bb50bbca9e33cb9c1b89d304b52169b8437b4c /dev-python/agate
parentdev-python/sphinx: Bump to 8.0.1 (diff)
downloadgentoo-eafc6ca65f77b7c4bae087c32ddd14325fd68633.tar.gz
gentoo-eafc6ca65f77b7c4bae087c32ddd14325fd68633.tar.bz2
gentoo-eafc6ca65f77b7c4bae087c32ddd14325fd68633.zip
dev-python/agate: Bump to 1.12.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/agate')
-rw-r--r--dev-python/agate/Manifest1
-rw-r--r--dev-python/agate/agate-1.12.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/agate/Manifest b/dev-python/agate/Manifest
index 230c5346c8e6..39fed7799927 100644
--- a/dev-python/agate/Manifest
+++ b/dev-python/agate/Manifest
@@ -1 +1,2 @@
DIST agate-1.11.0.tar.gz 203764 BLAKE2B c652f4f28840b036361fd05d5f1ca612fdb251a055f2e42d3859050907f0c0f0c17cb2a3351d5eb9d96759f18fc6851a501d1d3aabcb2ad257093ee97a96693d SHA512 9134987ed32838565e6d599568d5346e90d4623dca0868d13d134d6333d55f64ee4fc67469c691e1e964c735e14482e18615ca79f25108ffaf24c4da50a28ae6
+DIST agate-1.12.0.tar.gz 203989 BLAKE2B 790b1e04dce60754dc24dec367420dfeaacd15879940872d3231ea848b35d4149472285b0dcddd3749c37136b917fa718178de7401d6ca3322e249d56979fb3f SHA512 ba73717d1ad270161d2c5c8b45013c146e9ca0d8d7ca9b47e2db48818226544f66fd5762d5b956ea33add04a18bac46d9f0128e2022b98e0f78b3d2a7f0f1f1f
diff --git a/dev-python/agate/agate-1.12.0.ebuild b/dev-python/agate/agate-1.12.0.ebuild
new file mode 100644
index 000000000000..eb0e80daa1c9
--- /dev/null
+++ b/dev-python/agate/agate-1.12.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python data analysis library that is optimized for humans instead of machines"
+HOMEPAGE="
+ https://github.com/wireservice/agate/
+ https://pypi.org/project/agate/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/pytimeparse-1.1.5[${PYTHON_USEDEP}]
+ >=dev-python/parsedatetime-2.1[${PYTHON_USEDEP}]
+ >=dev-python/Babel-2.0[${PYTHON_USEDEP}]
+ >=dev-python/isodate-0.5.4[${PYTHON_USEDEP}]
+ >=dev-python/pyicu-2.4.2[${PYTHON_USEDEP}]
+ >=dev-python/python-slugify-1.2.1[${PYTHON_USEDEP}]
+ >=dev-python/leather-0.3.3-r2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/cssselect-0.9.1[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/furo
+
+EPYTEST_DESELECT=(
+ # require specific locales
+ tests/test_data_types.py::TestDate::test_cast_format_locale
+ tests/test_data_types.py::TestDateTime::test_cast_format_locale
+)