summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-21 08:41:58 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-21 08:51:12 +0100
commit34631fefe213be4f705463fd4c44e32050af0a59 (patch)
tree5174cf2aef9cb2c136c35e1e44bdaf6090c5312e /dev-python/asgiref/asgiref-3.6.0.ebuild
parentdev-python/pytest-skip-markers: Bump to 1.4.0 (diff)
downloadgentoo-34631fefe213be4f705463fd4c44e32050af0a59.tar.gz
gentoo-34631fefe213be4f705463fd4c44e32050af0a59.tar.bz2
gentoo-34631fefe213be4f705463fd4c44e32050af0a59.zip
dev-python/asgiref: Bump to 3.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/asgiref/asgiref-3.6.0.ebuild')
-rw-r--r--dev-python/asgiref/asgiref-3.6.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/asgiref/asgiref-3.6.0.ebuild b/dev-python/asgiref/asgiref-3.6.0.ebuild
new file mode 100644
index 000000000000..26047f0fd5a0
--- /dev/null
+++ b/dev-python/asgiref/asgiref-3.6.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="ASGI utilities (successor to WSGI)"
+HOMEPAGE="
+ https://asgi.readthedocs.io/en/latest/
+ https://github.com/django/asgiref/
+ https://pypi.org/project/asgiref/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest