summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-02 06:37:02 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-02 06:50:33 +0200
commit51bd605695a06f5265076d7dbc4d787a8ad2c955 (patch)
tree94defb6fd6b1c6ea9e9ca7a953a9607a5c7d7d52 /dev-python/asteval
parentdev-python/asteval: Remove old (diff)
downloadgentoo-51bd605695a06f5265076d7dbc4d787a8ad2c955.tar.gz
gentoo-51bd605695a06f5265076d7dbc4d787a8ad2c955.tar.bz2
gentoo-51bd605695a06f5265076d7dbc4d787a8ad2c955.zip
dev-python/asteval: Bump to 1.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/asteval')
-rw-r--r--dev-python/asteval/Manifest1
-rw-r--r--dev-python/asteval/asteval-1.0.2.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/asteval/Manifest b/dev-python/asteval/Manifest
index 4d68fd9ba446..4dece5d174be 100644
--- a/dev-python/asteval/Manifest
+++ b/dev-python/asteval/Manifest
@@ -1 +1,2 @@
DIST asteval-1.0.1.gh.tar.gz 45620 BLAKE2B ffa428e7a8c1ad13cef9872daddf50bf64816685c771832b5d61acfcd573d18f0ddf6212e2483deb67852d8f618c9dcce6687b38d3448dc374f1d373970d7b24 SHA512 f2af1f501446a62608e996f5633ab6f772c69c5177cac3ee255d79262728ce305d2a75402fdb1c34519ba67efbb4f261c3a959d7333adcaf819ac22e3d56709e
+DIST asteval-1.0.2.gh.tar.gz 45578 BLAKE2B 87bf6c9eaf4cb8f202bf78f8eb8b670fa7c4619384b8b07dd0b46fbba3f39508d16f69237a0798a705d5077fbe71930d7aa946e637668d5b41ec43d7b5802837 SHA512 6e7ae98e96c359852db46c3c2ba0fa9796375eea84b6f213fe59cf91fb3d9862effa759051e962daf6fc072579b907233166cd12ff4e9a2d04b62a519a8f9af8
diff --git a/dev-python/asteval/asteval-1.0.2.ebuild b/dev-python/asteval/asteval-1.0.2.ebuild
new file mode 100644
index 000000000000..5162e3ac4666
--- /dev/null
+++ b/dev-python/asteval/asteval-1.0.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Evaluator of Python expression using ast module"
+HOMEPAGE="
+ https://lmfit.github.io/asteval/
+ https://github.com/lmfit/asteval/
+ https://pypi.org/project/asteval/
+"
+SRC_URI="
+ https://github.com/lmfit/asteval/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ epytest -o addopts=
+}