summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-05-05 15:32:25 +0200
committerPacho Ramos <pacho@gentoo.org>2023-05-05 15:48:10 +0200
commit50257231b0acd884ebd7c2dc7cdb1f6e222bf201 (patch)
treeb59b92c424259220482f18579bf3b2ed9d020ac4 /dev-python/astunparse
parentmail-client/neomutt: Cleanup (diff)
downloadgentoo-50257231b0acd884ebd7c2dc7cdb1f6e222bf201.tar.gz
gentoo-50257231b0acd884ebd7c2dc7cdb1f6e222bf201.tar.bz2
gentoo-50257231b0acd884ebd7c2dc7cdb1f6e222bf201.zip
dev-python/astunparse: enable py3.11
Closes: https://bugs.gentoo.org/896750 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'dev-python/astunparse')
-rw-r--r--dev-python/astunparse/astunparse-1.6.3-r1.ebuild6
-rw-r--r--dev-python/astunparse/files/astunparse-1.6.3-test-py311.patch26
2 files changed, 30 insertions, 2 deletions
diff --git a/dev-python/astunparse/astunparse-1.6.3-r1.ebuild b/dev-python/astunparse/astunparse-1.6.3-r1.ebuild
index c00b8c24a796..9b2343f7d389 100644
--- a/dev-python/astunparse/astunparse-1.6.3-r1.ebuild
+++ b/dev-python/astunparse/astunparse-1.6.3-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1 pypi
@@ -25,8 +25,10 @@ RDEPEND="
PATCHES=(
"${FILESDIR}/astunparse-1.6.2-tests.patch"
- # from Fedora
+ # From Fedora
"${FILESDIR}/${P}-py39.patch"
+ # From Debian
+ "${FILESDIR}/${P}-test-py311.patch"
)
distutils_enable_tests unittest
diff --git a/dev-python/astunparse/files/astunparse-1.6.3-test-py311.patch b/dev-python/astunparse/files/astunparse-1.6.3-test-py311.patch
new file mode 100644
index 000000000000..f17ff76f0f6f
--- /dev/null
+++ b/dev-python/astunparse/files/astunparse-1.6.3-test-py311.patch
@@ -0,0 +1,26 @@
+From: Carsten Schoenert <c.schoenert@t-online.de>
+Date: Sat, 31 Dec 2022 12:01:26 +0100
+Subject: tests: Skip test_files() on Python >= 3.11
+
+Given functions from astunparse are now mostly "battery included" in
+Python 3.10 and ongoing und the test itself is only a small part of the
+testing I think it's o.k. to simply skip now this test until upstream
+will probably do some adjustment.
+
+Forwarded: https://github.com/simonpercivall/astunparse/issues/67
+---
+ tests/common.py | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/tests/common.py b/tests/common.py
+index 95b9755..7c8fa27 100644
+--- a/tests/common.py
++++ b/tests/common.py
+@@ -179,6 +179,7 @@ class AstunparseCommonTestCase:
+ os.path.join(getattr(sys, 'real_prefix', sys.prefix),
+ 'lib', 'python%s.%s' % sys.version_info[:2])]
+
++ @unittest.skipIf(sys.version_info >= (3, 11), "Ignoring if Python >= 3.11")
+ def test_files(self):
+ names = []
+ for test_dir in self.test_directories: