summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-17 04:28:25 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-17 04:52:18 +0200
commit556f94e9fc021d631cdaed95776515ff1b5da228 (patch)
tree6342ba4d6f7227d358dc82f8ab755b27e681a888 /dev-python/autopep8
parentdev-python/mkdocstrings: Remove old (diff)
downloadgentoo-556f94e9fc021d631cdaed95776515ff1b5da228.tar.gz
gentoo-556f94e9fc021d631cdaed95776515ff1b5da228.tar.bz2
gentoo-556f94e9fc021d631cdaed95776515ff1b5da228.zip
dev-python/autopep8: Bump to 2.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/autopep8')
-rw-r--r--dev-python/autopep8/Manifest1
-rw-r--r--dev-python/autopep8/autopep8-2.3.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/autopep8/Manifest b/dev-python/autopep8/Manifest
index 51b1ddbe819c..a3956d04e4dd 100644
--- a/dev-python/autopep8/Manifest
+++ b/dev-python/autopep8/Manifest
@@ -1,2 +1,3 @@
DIST autopep8-2.1.2.tar.gz 91299 BLAKE2B a38ed72306d77a517b2f510e46941aa2fe572b4d51e9c8ee9c817798d5e1db964c0f2f436de9be22553557335a9291074870694ca4ac1e054b4cfd9de9db71a5 SHA512 296f3463f5a7088029e4a6cfefcf9b93a8be1798e6c81818d362d801b97d76bb107619c7724d9f1557006223e9514bc5044f2cec24d8c896c7e420431eb2252d
DIST autopep8-2.2.0.tar.gz 91723 BLAKE2B 6d00f689752cb134e11e46bbb617d274afbacb30f4f337270cfd00aa9a4dc1cd6f3754a1b0c53986d0350821475b91126ae14bb2464f25fa5f24afb9f9c13c73 SHA512 2a2441e742b3172c011dc142d8d24c439c17fc9b3733c0fc161d30914e1cea50b45c85a66e20c435a828629f1cd1e3f699c1b1a102db0bf721efe8b1e7c91c43
+DIST autopep8-2.3.0.tar.gz 91624 BLAKE2B 8da037adfe18cf3a470cd8f50cca176999193c28409ca35cf398cde9bf2dc094e59d55b6e7d60348afcf244039b9f37167ff2c672d9a1a1bf4cc9aff7343785a SHA512 e76ffcc242f3ae4c75e1f2831158fdcd154c993bc16d61f0b6b5a08259d47c418986ebdea22c74f8703e7018c66f7fa8658ba993b15ff3b40b92d0e8c5edfd40
diff --git a/dev-python/autopep8/autopep8-2.3.0.ebuild b/dev-python/autopep8/autopep8-2.3.0.ebuild
new file mode 100644
index 000000000000..814d492a2374
--- /dev/null
+++ b/dev-python/autopep8/autopep8-2.3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="
+ https://github.com/hhatto/autopep8/
+ https://pypi.org/project/autopep8/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/pycodestyle-2.11.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+
+distutils_enable_tests pytest