summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-17 09:39:26 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-17 09:39:26 +0300
commit13bb7bddc28b9a2b0cb06c9a66fc49de9fd781fd (patch)
tree4e15c875f05cfff8b0b79087cc86e19e393b18e1 /dev-python/bashate
parentdev-python/ament_package: EAPI=8, PEP517 (diff)
downloadgentoo-13bb7bddc28b9a2b0cb06c9a66fc49de9fd781fd.tar.gz
gentoo-13bb7bddc28b9a2b0cb06c9a66fc49de9fd781fd.tar.bz2
gentoo-13bb7bddc28b9a2b0cb06c9a66fc49de9fd781fd.zip
dev-python/bashate: Use PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/bashate')
-rw-r--r--dev-python/bashate/bashate-2.1.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/bashate/bashate-2.1.0-r1.ebuild b/dev-python/bashate/bashate-2.1.0-r1.ebuild
new file mode 100644
index 000000000000..5d960626e724
--- /dev/null
+++ b/dev-python/bashate/bashate-2.1.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A pep8 equivalent for bash scripts"
+HOMEPAGE="https://pypi.org/project/bashate/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest