summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/blockcanvas
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/blockcanvas')
-rw-r--r--dev-python/blockcanvas/Manifest1
-rw-r--r--dev-python/blockcanvas/blockcanvas-4.0.3-r1.ebuild54
-rw-r--r--dev-python/blockcanvas/metadata.xml15
3 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/blockcanvas/Manifest b/dev-python/blockcanvas/Manifest
new file mode 100644
index 000000000000..a5d4dde62bfc
--- /dev/null
+++ b/dev-python/blockcanvas/Manifest
@@ -0,0 +1 @@
+DIST blockcanvas-4.0.3.tar.gz 1125887 SHA256 8cbd5d19cbb2008596ef0deb554988f9af480d81328ec58f1225dc1170517b9e SHA512 c74bebceafca28646186c72efd20168113cc62ac17b598e12074d029dce1803a601aafba31b5a305bdbf6d74d5d7bf29614b917e21bd54df7db123701ea770c1 WHIRLPOOL b1bae62c91d3d35ebe3cdaeca375ab2568951c97c4d7541a57dc64557565749968b99b615cf4f7bd37c30293bc642bcc544e697fb17efe580e6e0b9b9f6909fc
diff --git a/dev-python/blockcanvas/blockcanvas-4.0.3-r1.ebuild b/dev-python/blockcanvas/blockcanvas-4.0.3-r1.ebuild
new file mode 100644
index 000000000000..ad29111688b7
--- /dev/null
+++ b/dev-python/blockcanvas/blockcanvas-4.0.3-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Enthought Tool Suite: Numerical modeling"
+HOMEPAGE="http://code.enthought.com/projects/block_canvas/ http://pypi.python.org/pypi/blockcanvas"
+SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+RESTRICT=test
+
+RDEPEND=">=dev-python/apptools-4[${PYTHON_USEDEP}]
+ >=dev-python/chaco-4[${PYTHON_USEDEP}]
+ >=dev-python/codetools-4[${PYTHON_USEDEP}]
+ >=dev-python/etsdevtools-4[${PYTHON_USEDEP}]
+ >=dev-python/pyface-4[${PYTHON_USEDEP}]
+ >=dev-python/scimath-4[${PYTHON_USEDEP}]
+ >=dev-python/traitsui-4[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/greenlet[${PYTHON_USEDEP}]
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc
+ )"
+
+DOCS=( docs/{notes.txt,readme.txt} )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ VIRTUALX_COMMAND="nosetests -v" virtualmake
+}
+
+python_install_all() {
+ use doc && local DOHTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/blockcanvas/metadata.xml b/dev-python/blockcanvas/metadata.xml
new file mode 100644
index 000000000000..b369e5fc9be7
--- /dev/null
+++ b/dev-python/blockcanvas/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ The Enthought Tool Suite BlockCanvas project provides a visual
+ environment for creating simulation experiments, where function
+ and data are separated. Thus, you can define your simulation
+ algorithm by visually connecting function blocks into a data flow
+ network, and then run it with various data sets (known as
+ "contexts"); likewise, you can use the same context in a different
+ functional simulation.
+ </longdescription>
+</pkgmetadata>