summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-05-13 09:48:36 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-05-13 10:50:28 -0400
commit852cbcf172a9841a547954dab4df59d241e9c25a (patch)
tree7444d484a0687d8139108567e88ee46516901c5c /dev-python/boltons
parentdev-python/lazy-object-proxy: enable py3.11 (diff)
downloadgentoo-852cbcf172a9841a547954dab4df59d241e9c25a.tar.gz
gentoo-852cbcf172a9841a547954dab4df59d241e9c25a.tar.bz2
gentoo-852cbcf172a9841a547954dab4df59d241e9c25a.zip
dev-python/boltons: use pep517
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-python/boltons')
-rw-r--r--dev-python/boltons/boltons-21.0.0-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/boltons/boltons-21.0.0-r1.ebuild b/dev-python/boltons/boltons-21.0.0-r1.ebuild
new file mode 100644
index 000000000000..34374fc8ae2a
--- /dev/null
+++ b/dev-python/boltons/boltons-21.0.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Pure-python utilities in the same spirit as the standard library"
+HOMEPAGE="https://boltons.readthedocs.org/"
+SRC_URI="https://github.com/mahmoud/boltons/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
+
+DOCS=( CHANGELOG.md README.md TODO.rst )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-python3.10.patch
+)
+
+python_test() {
+ # failure in test_exception_info with pytest-qt
+ epytest -p no:pytest-qt
+}