summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-16 04:08:30 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-16 04:08:30 +0100
commit00912377f6309ff562459b1e7dd44069f97bf024 (patch)
tree21a72fe0a5f15fe5b449ad2ee3cb26d7a7be8e0a /dev-python/boto3
parentdev-python/botocore: Bump to 1.32.1 (diff)
downloadgentoo-00912377f6309ff562459b1e7dd44069f97bf024.tar.gz
gentoo-00912377f6309ff562459b1e7dd44069f97bf024.tar.bz2
gentoo-00912377f6309ff562459b1e7dd44069f97bf024.zip
dev-python/boto3: Bump to 1.29.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.29.1.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index a3c7b54ec5b2..e8404682d73a 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -2,3 +2,4 @@ DIST boto3-1.28.78.gh.tar.gz 724185 BLAKE2B 5089a7d1eab11c23bd65699c41c3c6687f06
DIST boto3-1.28.84.gh.tar.gz 728124 BLAKE2B 2fcc553a4a109b0bc92cdf0b08fe77fcef54792ee606b6b9ed7cde1ae92accabb9f9ce005d9ccd391601efac31eec407345471542c5b7298689ab1037ed8f41f SHA512 1b7f1fe951a9f3655a71bd51e9328f4474f9b320df82914b9ad0d64a32043aacf16fc5df1989304fd4d35430ddf6f58d0676fdb3985944d955c169a0ec58ce7b
DIST boto3-1.28.85.gh.tar.gz 728751 BLAKE2B bfbc9b26b45e034949f13492987fdd43476d428d84da8b15e1ac67647acb410823bcc5e8710126a062a40779357ea49b5b4e1038831d38239515a793c6601dd4 SHA512 96165e6e5bd5673a364be445ab21916115e4f58c9e499f58bf0098d37fb7ba6ef28d5a6046f452e26618a305eb9713f5b5e5f10fd0c22868c499a9870fea4bef
DIST boto3-1.29.0.gh.tar.gz 730038 BLAKE2B 3f6f853eaa18d66ffef1e159fb641e6e3d069b1cb8ca9df457a714b1682a210ccf52aca4900172812b195309a4cd1a179c4ff2dff2f0a3c519e73c1eb9380908 SHA512 d826bda41fcab62b9e868ad96e405d538f1af1b7bc31c96349330fce493c8efef282c1da1c47a45a4a0e0e3051c0ddb0847af1efc9e7e9a87419f3995db2a5ca
+DIST boto3-1.29.1.gh.tar.gz 731491 BLAKE2B 15d7aa771369afac957d1c0fac1c0cca9fb4322a7643d9dc2cb688908ab80c9f3815b92e9645266be0547d45959b6f2f20891ced2da0ab33df2de966dcfa510b SHA512 c07fb0bc3daab7aa6c21cec278b246b4df20f9e665b379f8005d2239a1d0bb637304d7308f1479b772ee314b99559bdb7f5c37503d6a9ef6801999270637cf87
diff --git a/dev-python/boto3/boto3-1.29.1.ebuild b/dev-python/boto3/boto3-1.29.1.ebuild
new file mode 100644
index 000000000000..0604e0996a82
--- /dev/null
+++ b/dev-python/boto3/boto3-1.29.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}