summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-18 06:25:41 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-18 06:25:41 +0100
commit8c2ec2979041a9662fcee53300c304ad0739f4b5 (patch)
tree79c873a022eabb040f1e15e7fe3dbb5927e746e0 /dev-python/boto3
parentdev-python/botocore: Bump to 1.32.3 (diff)
downloadgentoo-8c2ec2979041a9662fcee53300c304ad0739f4b5.tar.gz
gentoo-8c2ec2979041a9662fcee53300c304ad0739f4b5.tar.bz2
gentoo-8c2ec2979041a9662fcee53300c304ad0739f4b5.zip
dev-python/boto3: Bump to 1.29.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.29.3.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 55b0ba1af8d5..e3a4b47310f9 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -4,3 +4,4 @@ DIST boto3-1.28.85.gh.tar.gz 728751 BLAKE2B bfbc9b26b45e034949f13492987fdd43476d
DIST boto3-1.29.0.gh.tar.gz 730038 BLAKE2B 3f6f853eaa18d66ffef1e159fb641e6e3d069b1cb8ca9df457a714b1682a210ccf52aca4900172812b195309a4cd1a179c4ff2dff2f0a3c519e73c1eb9380908 SHA512 d826bda41fcab62b9e868ad96e405d538f1af1b7bc31c96349330fce493c8efef282c1da1c47a45a4a0e0e3051c0ddb0847af1efc9e7e9a87419f3995db2a5ca
DIST boto3-1.29.1.gh.tar.gz 731491 BLAKE2B 15d7aa771369afac957d1c0fac1c0cca9fb4322a7643d9dc2cb688908ab80c9f3815b92e9645266be0547d45959b6f2f20891ced2da0ab33df2de966dcfa510b SHA512 c07fb0bc3daab7aa6c21cec278b246b4df20f9e665b379f8005d2239a1d0bb637304d7308f1479b772ee314b99559bdb7f5c37503d6a9ef6801999270637cf87
DIST boto3-1.29.2.gh.tar.gz 734398 BLAKE2B bc2816fd37130d4957873964b4020ec90f106fef5d034c4b47e9485610d577cdcac3106b66dcf20175335fcc49773dadcdabab9de65fb85caeddf5bea0845184 SHA512 dc5faf76f2949506db24888780cc07c792903707e54853258182a016b4b1b4f91ae79467e5f140ba0ce822d99e4fc570a16168211b10296bd9820eb245d9cbc5
+DIST boto3-1.29.3.gh.tar.gz 737012 BLAKE2B 4282de0bbe03b61cf6884b08cf0a16e93c1e27a0323d2eee93277f8ac62f5ef440612292ebc245f13de0bbac9c156cae0cd5c76e8ae5b7d018a125cd49a682df SHA512 e42064e2c825376dfe2a5aa0c92715d06d6d29c3cf8b194d8742c688a4743e216ba32111bba080d88505907e48ff26086106eaef62fa5048f34fcbf08355ab60
diff --git a/dev-python/boto3/boto3-1.29.3.ebuild b/dev-python/boto3/boto3-1.29.3.ebuild
new file mode 100644
index 000000000000..0604e0996a82
--- /dev/null
+++ b/dev-python/boto3/boto3-1.29.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}