summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-22 06:49:38 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-22 06:49:38 +0200
commitd7eb8d50e3e37326918fada84c88d51b6b42994d (patch)
treeb22af2fdf505ec97a75e33674acfcd832da0b67e /dev-python/boto3
parentdev-python/botocore: Bump to 1.31.9 (diff)
downloadgentoo-d7eb8d50e3e37326918fada84c88d51b6b42994d.tar.gz
gentoo-d7eb8d50e3e37326918fada84c88d51b6b42994d.tar.bz2
gentoo-d7eb8d50e3e37326918fada84c88d51b6b42994d.zip
dev-python/boto3: Bump to 1.28.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.28.9.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index eac64a3fd286..6ac720769c0e 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -14,3 +14,4 @@ DIST boto3-1.28.4.gh.tar.gz 675638 BLAKE2B e5d4cd28b61a79c54c28355003a097f7b40c5
DIST boto3-1.28.5.gh.tar.gz 676044 BLAKE2B b54fb3a76b9cf67a07ae95b669b6eb5a1a26aa105ea2d3a36a638099741411103f6714a50cfbd57a25b1aeeafb497d66d0324496e5986efa8aea97fc1e522d84 SHA512 437b332121384def9a16a1e83f39fd83564189421bb9d27d8f7f9f5976ca08c1089729b2ea2f9c66c200cf2f78c27c3da120d4b8fdf76b2a68f9ced2e8576c27
DIST boto3-1.28.6.gh.tar.gz 676887 BLAKE2B 997ea4b082bd427461babcbca5f5a230df0a6479359a40193698eb629be88528799c7912ff8194053f50a7d3b8c5e5e78477be5958943d22166b7f9d3f7bfb91 SHA512 67beb7986d514c8695025d5becad5e562a955b97970e26c878b80fb076d877a1479742aac74563a73569e8f5e4ccd465e564751b236147c8fc64da0855b93368
DIST boto3-1.28.8.gh.tar.gz 677637 BLAKE2B 19f91014a394b67854ac0fc04a7b8a3e1bfb3df5a1b2f5717a739d8b2461ca049dfff7fefb9145432002742ae8613ef13a7d63b56f63bd6bddb81fb58197f625 SHA512 e6e48c601d6426b94ec648438381f0b9960af760e1a5889677124c41ffe2cff54da84b1a4be6dbfce6fcf57a5fcda74b8b9745f709cf7e1031ec4928d7c73b2d
+DIST boto3-1.28.9.gh.tar.gz 677993 BLAKE2B a800de94cfb0d317b41091fb1d2bb0fd6449df85da434879c0689bf36998b2a52331ba077c65cae9967fcce998a15d2a6f6a758931fa12a00b95487adaf81dfa SHA512 6e1e5e74d20d2e67f29597ddcda70475cbea863978ca93ec77a0f478690477c9782111701771d5b8354f4402c21496e7f5627b1398cbd6fd87627fd978f5e360
diff --git a/dev-python/boto3/boto3-1.28.9.ebuild b/dev-python/boto3/boto3-1.28.9.ebuild
new file mode 100644
index 000000000000..2a4a7643203e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.28.9.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}