summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-13 05:46:46 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-13 07:15:00 +0100
commit14669aeed3e92421927c0d8c8a181bd5184d83e2 (patch)
tree848f92d7d85f2d18c591d6b5a914bc7652e24332 /dev-python/botocore
parentsys-apps/etckeeper: add 1.18.22 (diff)
downloadgentoo-14669aeed3e92421927c0d8c8a181bd5184d83e2.tar.gz
gentoo-14669aeed3e92421927c0d8c8a181bd5184d83e2.tar.bz2
gentoo-14669aeed3e92421927c0d8c8a181bd5184d83e2.zip
dev-python/botocore: Bump to 1.35.80
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.35.80.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index ea9370b9448c..81eb18b66224 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -4,3 +4,4 @@ DIST botocore-1.35.76.gh.tar.gz 14117270 BLAKE2B b072b926daae520e54871676d5afc48
DIST botocore-1.35.77.gh.tar.gz 14120607 BLAKE2B bc5f22133796be3b2749f848d62c9eeff6f58a515393beda2f41df9c734eb7167a97987d06e025ebc2693eea6214dd0f7788f9f4cf1e5ac71a91b05b6e886d7e SHA512 fa699fbffc2e7f1e9062fe1393f1cef4677cb30b5090df55bb84b4719e880a6731731ab2799450ab06f70f9a057e749529c283ebe6400b7b35e7b89a2c22eb2a
DIST botocore-1.35.78.gh.tar.gz 14124766 BLAKE2B 53bb6a8cf63bb69c5e827e269f6efc35b56919c878eadf10f7a7017848703f8de682a7d1912965f40bbb0c0c2903a6d22a4479c8f66ec03c57410f6e3b27dc70 SHA512 74816012870b25a7344096e714c2c9319cd9ac676a3d5e194d68dcc6eaa048233630c30d33ba6ac02f2c953148f704ca068f4aead562504eba893b468408aac0
DIST botocore-1.35.79.gh.tar.gz 14134346 BLAKE2B e3fdc5510c0ed8a693e9f34568c6918a6907c74d95e4b309725b3ba825c83a7c9f924cac0a8e7ab0cfae5ed038b9f999a1e9b9a3ade3637f630e6ac63b68ae43 SHA512 00d6c614fa65ac86cce5ece0a939a5656922e09f30a9bd19e503c5c9442c299d1b2f2d37ef4b062193e22b123636ee4568f8b903994514c53b7c35ad6f2a7047
+DIST botocore-1.35.80.gh.tar.gz 14140449 BLAKE2B e007303a833e2e430791b6ec52d63686be4680fb83f03add317bb5952cf1c64d5949c42ee558579569f0c802e9386cc71aab1ab447870268d9dcf700ecf0e9f9 SHA512 0b03cfaa2e688c8df8ec5310606dbce4a08593675f7723a55c2ba85b6b45a37dda46ebd861a849301fc66d3d826dd2ffe162571869c461e34160c3ce7f42eed1
diff --git a/dev-python/botocore/botocore-1.35.80.ebuild b/dev-python/botocore/botocore-1.35.80.ebuild
new file mode 100644
index 000000000000..0f88c5cbe9f3
--- /dev/null
+++ b/dev-python/botocore/botocore-1.35.80.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}