summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-16 04:08:22 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-16 04:08:22 +0100
commit720d39abea46e2eed3d5c9523c7bd9628633ee7b (patch)
tree021f3c473aec6940f80fcf44cf212eea1e1dea85 /dev-python/botocore
parentnet-wireless/qdmr: add 0.11.3, drop 0.11.1 (diff)
downloadgentoo-720d39abea46e2eed3d5c9523c7bd9628633ee7b.tar.gz
gentoo-720d39abea46e2eed3d5c9523c7bd9628633ee7b.tar.bz2
gentoo-720d39abea46e2eed3d5c9523c7bd9628633ee7b.zip
dev-python/botocore: Bump to 1.32.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.32.1.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index db464279158c..a194efcf7678 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -2,3 +2,4 @@ DIST botocore-1.31.78.gh.tar.gz 12035206 BLAKE2B 0dd1109d34a8cf99af76f1f61509577
DIST botocore-1.31.84.gh.tar.gz 12065719 BLAKE2B 2098241de47aa1f59c45287c2be66fa3562c2e549da081b1cd86626f1df5f3f175eebea1197396f39045aaebda241d37b1d47ebb378a0fb17e43c16215f89680 SHA512 097a25b4450513cf9c2722d7582cdfb969da8c083c05603f6a28eb65d1d69920106c745cb4f5e5b3bee1989eee64c89fe69c379f01df938edf2a92946c614cdf
DIST botocore-1.31.85.gh.tar.gz 12070341 BLAKE2B b4867e351d209511db263654873f5a804f941c44d10af563eec656b041830c8543f2ec1f8d831a0aec2cce4d9b7dfc80bd3e73fd5fc456cf5e3ca00ab193b11d SHA512 0e26b6ad06e1075ec90f04d653873592fcc2ae4bdbec5bbbe4b38e368824bf000724551ac2598938b827ce81e3b327ffa9d5d23da0ccb915686a70e0f37ba161
DIST botocore-1.32.0.gh.tar.gz 12086167 BLAKE2B 54e580c4d034b437d1e2e7748f1dd4785354db87459116565bc15d60bd73fe5d46cade212fd44fabd243614f3be55d9eeaef575ea6d6312ad83c0b6c1e741515 SHA512 9aba3cc3f823ba47ee7964517189d1227e5934c63ecdf1631ade59524594fb7cc20b9cfc7060dd8a69648d48e2d1ede0a377f204124d06ef843dd98a4cd1b11f
+DIST botocore-1.32.1.gh.tar.gz 12098630 BLAKE2B 3a2501da4bd2ec8d29f032a2df4d7946840682df426b4496f60bab487b0eb47580314b4c3029dded6a589463a8636c362c560fd4c2da02c113647ee10ebf079d SHA512 4ec58dcf896ef46f27f3c4af7c6e58efad62e5c2e3fb9aa8de9a90ee390d65b036116d9d8ba7c766b95b03e6e85e909cc620b838511152004dbcfb67968525b4
diff --git a/dev-python/botocore/botocore-1.32.1.ebuild b/dev-python/botocore/botocore-1.32.1.ebuild
new file mode 100644
index 000000000000..05766e84276c
--- /dev/null
+++ b/dev-python/botocore/botocore-1.32.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x EPYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}