summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-25 05:21:14 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-25 10:01:33 +0200
commit7d5649a23489279c8e69437c7200f06bc0e4760e (patch)
tree6ef0bb7e23fd8ba1077194d78b42d88e8e289567 /dev-python/botocore
parentdev-python/aws-xray-sdk: Remove old (diff)
downloadgentoo-7d5649a23489279c8e69437c7200f06bc0e4760e.tar.gz
gentoo-7d5649a23489279c8e69437c7200f06bc0e4760e.tar.bz2
gentoo-7d5649a23489279c8e69437c7200f06bc0e4760e.zip
dev-python/botocore: Bump to 1.34.132
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.34.132.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 8dfcae552b25..a692b820d4fc 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,3 +1,4 @@
DIST botocore-1.34.122.gh.tar.gz 13066937 BLAKE2B f22af79873b5574ae4b2b9041568cfc1d727625c3fa45c9b8d1bef71ffcce893aa8a3591c83160437c7e617be72814a2209569db633d857f869a2152af7c8e05 SHA512 f08dcb2920d4bd26a47478edb871f75b240275a7b96acf58be838080dddca3d4f64b9fda8683e5a3db97defe367298b2ba634fc4d605523805b23c83c3a5ae0d
DIST botocore-1.34.127.gh.tar.gz 13112261 BLAKE2B e883f0a1e29178667678132195aea9666a124456e731e1b158eed895c125fd614e5671639766f7ad46c2e6b16c4156ff5e42594bc04e49bf25380c91cfcbe264 SHA512 48ca2179c24bb219202e5029dd62350a6fc5c64707762f0f33282e542dbc2227bb146376afa9e6b9eb1e45e3c801208a142bef4827d5036eb4724299c826d534
DIST botocore-1.34.131.gh.tar.gz 13129943 BLAKE2B 916360c6a9526edcfd338718f80556e59d54692aac13f38490e49457edd59016d264a5acbfeb6298af494f09f9c385e16347a9bf7f144c5a11afda2df188aeed SHA512 9bb788ac8e8a2ec7be999acafef88ccbb4e693ccb315efe5655b80cf3f6629eebccbdac6f201550d2f75e476d83c5a800f1add6c71e2fe5b3d503da313f6d3d3
+DIST botocore-1.34.132.gh.tar.gz 13131027 BLAKE2B 044d1ad5d843a8fa924ba71d66e025cf81ff7c0f1b6d47bb52d0b38ea9a25617218b9789449bbee782010daefa328e6d7327e7663133bc624143c71749876a00 SHA512 b029fdebeb9cce956bbe012b2145131368e93a9d255f9253ce0780d1b311061b8ce3353e1d3a083616dec299e1d8d4c829f58f1414781971c0122ee43d80c869
diff --git a/dev-python/botocore/botocore-1.34.132.ebuild b/dev-python/botocore/botocore-1.34.132.ebuild
new file mode 100644
index 000000000000..ba6cd2a5d2a2
--- /dev/null
+++ b/dev-python/botocore/botocore-1.34.132.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}