summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-06 06:24:00 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-06 07:29:15 +0200
commita669a7ca8da5839ca78b9a8f19da7a6f1ce4e10e (patch)
treea92d8c6d0a3c869ed7ab53ef7ba5401cd2cae336 /dev-python/botocore
parentnet-firewall/ipset: Stabilize 7.22-r1 x86, #935577 (diff)
downloadgentoo-a669a7ca8da5839ca78b9a8f19da7a6f1ce4e10e.tar.gz
gentoo-a669a7ca8da5839ca78b9a8f19da7a6f1ce4e10e.tar.bz2
gentoo-a669a7ca8da5839ca78b9a8f19da7a6f1ce4e10e.zip
dev-python/botocore: Bump to 1.34.140
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.34.140.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index b1aa34985927..6bb8463c7bc2 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -4,3 +4,4 @@ DIST botocore-1.34.136.gh.tar.gz 13151618 BLAKE2B 800b800ff2481335f0defb79c10a42
DIST botocore-1.34.137.gh.tar.gz 13153450 BLAKE2B 4049e5f7b12a4df94fa4a819f11732b86897ae838cc1fc9443f343037915e69134c0e3f335796976002ca63305dd12a8272252bed9370b6d64dc83186826467f SHA512 f3ba697813ec4a68978f27be12e44df02336210e47b5347f3868c4630d899eccf4cb0e0cc679122e4e5ae55ba002efc7067e6e13ea5a286707b958cae14b4186
DIST botocore-1.34.138.gh.tar.gz 13153609 BLAKE2B d2f16e1c49b51dbe35e21774bac766b88ad83cad18c6ee972de7f83086d1d00eb70826dbc0ffaff2b4bdb916fa22a849c1c0b8a4980206d9fb8c8288a047d803 SHA512 a43deaa3a5e95dbaa3a018907b8b44b822c399542f91291963e31708efbe06ca566f5f1290ba9c13359ebcac3566586d5b1c4ba391778ca11ed2d09ef1335162
DIST botocore-1.34.139.gh.tar.gz 13155941 BLAKE2B 8c916972478f947f75cc9e864904da5f9304d8ae1e454ff2777d943ffc7fec6959c34ade893ce74d7b63cc15133317dab4b3610ec0ad8f7e73255d37411a2cf0 SHA512 6cd86c0bbebf9251060dd2b16962dbc514bb487c33fb13301a7d8e4e036d56f9c20a252e89be94209962ff83d253eba4e568babbf8c6b93987274050c48a6e3c
+DIST botocore-1.34.140.gh.tar.gz 13156596 BLAKE2B 4a264fe767c35dcc65ddbe1eb29529d2576553e4d6f9a3d6c28f249aaa0eab5a0fd150fdbdc1dbd1b83cc1fb6fce8f58c68de43f5dc338cb3feb5b9f76c8f973 SHA512 36c90da9670639ccc10e65ced501a2b16e50b664f11be2686f6fcfc56fa81271f160b27b7ffac513446afe09ef6ed4768818ad8b8ca540571737c47fdf980443
diff --git a/dev-python/botocore/botocore-1.34.140.ebuild b/dev-python/botocore/botocore-1.34.140.ebuild
new file mode 100644
index 000000000000..ba6cd2a5d2a2
--- /dev/null
+++ b/dev-python/botocore/botocore-1.34.140.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}