summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-15 08:12:17 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-15 08:35:07 +0100
commita7a5854d65d177fa099f476ae1f3f615d8f5d6b7 (patch)
treead2d6ebe79a6b58a24abf66b89828bc962456e25 /dev-python/botocore
parentdev-python/google-api-core: Add python@ as co-maint (diff)
downloadgentoo-a7a5854d65d177fa099f476ae1f3f615d8f5d6b7.tar.gz
gentoo-a7a5854d65d177fa099f476ae1f3f615d8f5d6b7.tar.bz2
gentoo-a7a5854d65d177fa099f476ae1f3f615d8f5d6b7.zip
dev-python/botocore: Bump to 1.19.55
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.19.55.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index d181dd022679..9b078e405d26 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -6,3 +6,4 @@ DIST botocore-1.19.51.tar.gz 7385977 BLAKE2B 505dd818f001b11f248582ec0f24bb7aac2
DIST botocore-1.19.52.tar.gz 7386245 BLAKE2B 53e21b0c3e39bb3c7219e785b79a167e082f7de7a6c54b2c0e5c53f565c41f76042a9ccd1e2c7ae2e68e19ac2c43d9ce104f1ecfd6c606dead2533a319c969af SHA512 deb827631ffbed9980adc47f05e96d800dc2c65f67a156bbe29e3cd34e612169fc4169e173d06fb9fe42c92ddb1e5041dbd02ad838b80f82657b5bd851aa8fba
DIST botocore-1.19.53.tar.gz 7387325 BLAKE2B 3432c9d71f7a021184c2ac99be9213015951d1bba445788dcb388a518b62a96a4d3871577d5e97f4f86f7b0830a009155667b05a960b1d06642599e3d4d484e4 SHA512 ffe1da3076e656c36f4c59c12fa9f466e63b6bbc0365f7ecb78a6dc6941eb3748d676188c2b0e5a2d23d21e5cb03daf2893aa04561e183dc931070fae77eea9f
DIST botocore-1.19.54.tar.gz 7387625 BLAKE2B f3d6a36e5659fb96bdffdf3b7dfdde29c7af7f8437a1ba9722fd1b7c7c817d6a2e54500a6cce4784b7cff4e06342d317615cba048347ddd284dec978d5159e0e SHA512 1f5e0af14bb3e6ff57070580c72caeadfbdf64b8e24951053d991120ddd0d835e025d1211bfeff0f4932821e0c36f82514168ce785a316aac5ebee1feb073e6f
+DIST botocore-1.19.55.tar.gz 7389560 BLAKE2B 887b78625ef9a1d526850d2dba65d4dd4c9dc913ba6716e457d74ede4483a4e77fc401fc102f37150acec9f3d66511543615d73c5a380a354915b964dead1e8e SHA512 fd86ac2770bfebb3618faf3ccbbe003526dc97a0c233465eb26f83e9946a8710377c27811d8c8869b2cb8eec4f183555a47131968f57ab80529279d287ed9642
diff --git a/dev-python/botocore/botocore-1.19.55.ebuild b/dev-python/botocore/botocore-1.19.55.ebuild
new file mode 100644
index 000000000000..fa25adc1c1ff
--- /dev/null
+++ b/dev-python/botocore/botocore-1.19.55.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}