summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-12 06:09:19 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-12 06:56:55 +0200
commite974be11815c5c4f1d3e4af8c2b60f068de6e56f (patch)
tree98254b15caba056f1c0c9f3dc4765ce8f345a46c /dev-python/botocore
parentdev-libs/openssl: add 3.2.2 (diff)
downloadgentoo-e974be11815c5c4f1d3e4af8c2b60f068de6e56f.tar.gz
gentoo-e974be11815c5c4f1d3e4af8c2b60f068de6e56f.tar.bz2
gentoo-e974be11815c5c4f1d3e4af8c2b60f068de6e56f.zip
dev-python/botocore: Bump to 1.34.124
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.34.124.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 7259774e09d9..a922f25ad7ee 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -2,3 +2,4 @@ DIST botocore-1.34.113.gh.tar.gz 13060395 BLAKE2B 8f9329d613f489f2305d068566940a
DIST botocore-1.34.117.gh.tar.gz 13076178 BLAKE2B defbd66d6409004fe49df44aec0a00b4bbe1a459d3e4b067c5c8609b998c63e7d62c8d3c48805416d44c08aeb3ab261f4449cc7e6a7c66dd3ca5f97bdcce291f SHA512 d9736ddb868e602afbaad95989d284b2835636f273e8a4263caa7eec619fe7cc45515fbbe98d4fd33121fe0d97d34353f7cd811bc878a81d1f5f7437798b24d6
DIST botocore-1.34.122.gh.tar.gz 13066937 BLAKE2B f22af79873b5574ae4b2b9041568cfc1d727625c3fa45c9b8d1bef71ffcce893aa8a3591c83160437c7e617be72814a2209569db633d857f869a2152af7c8e05 SHA512 f08dcb2920d4bd26a47478edb871f75b240275a7b96acf58be838080dddca3d4f64b9fda8683e5a3db97defe367298b2ba634fc4d605523805b23c83c3a5ae0d
DIST botocore-1.34.123.gh.tar.gz 13080868 BLAKE2B a15ecc1151803d26181c72117df62a6777c2d209cc1a49eb106d7a779fab23300762d8e034e9dc79c8eb747d6e31b5ea75739698809797bea9fe3c930b72b40a SHA512 20f77200edd899b957c7544ba7faed4fb7fd6a0fb6c0fe95cd729c67b3f47bb2414ed413c145fcc9e0f1e55f2cee86398580b9b71d38b70043d01efbe48e9510
+DIST botocore-1.34.124.gh.tar.gz 13097299 BLAKE2B 1dd7353ca2ae93199995530057cdd90dbaf1a4e493ca7be1e7b4cc445dfa0d352f02b903a6264dd67105f2826df05ed01aa1a861545ab28369519183b731365a SHA512 5e53a80571811faa306926aa7f72d802f720040c6a613aacadcb00e331259185ccfed91bd1fdffefddc069ae58cd80454b182d4965273bc10921cb2625ebf793
diff --git a/dev-python/botocore/botocore-1.34.124.ebuild b/dev-python/botocore/botocore-1.34.124.ebuild
new file mode 100644
index 000000000000..ba6cd2a5d2a2
--- /dev/null
+++ b/dev-python/botocore/botocore-1.34.124.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}