summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-02-26 16:43:38 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-02-26 18:02:05 +0000
commit64accd661ade02435683e872382fe9cdbc30c8d7 (patch)
tree69a962789746ee61ed5ae4cd5b275d5ef263b7b0 /dev-python/breathe/breathe-4.6.0.ebuild
parentdev-python/ginga: version bump (diff)
downloadgentoo-64accd661ade02435683e872382fe9cdbc30c8d7.tar.gz
gentoo-64accd661ade02435683e872382fe9cdbc30c8d7.tar.bz2
gentoo-64accd661ade02435683e872382fe9cdbc30c8d7.zip
dev-python/breathe: initial import
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/breathe/breathe-4.6.0.ebuild')
-rw-r--r--dev-python/breathe/breathe-4.6.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/breathe/breathe-4.6.0.ebuild b/dev-python/breathe/breathe-4.6.0.ebuild
new file mode 100644
index 000000000000..06f88131dadb
--- /dev/null
+++ b/dev-python/breathe/breathe-4.6.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx Doxygen renderer"
+HOMEPAGE="http://breathe.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ app-doc/doxygen[latex]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"